summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG4
-rw-r--r--modules/pam_tally/Makefile10
-rw-r--r--modules/pam_tally/pam_tally.c2
3 files changed, 11 insertions, 5 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 46039d9a..6be2f928 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -49,6 +49,10 @@ bug report - outstanding bugs are listed here:
0.76: please submit patches for this section with actual code/doc
patches!
+* pam_tally: added an #include (was it really needed?) and made the
+ pam_tally app install (with more pretty printing and a corrected
+ Makefile dependency) motivated by a (red hat diff) courtesy of Harald
+ Welte (Bug 436432 - agmorgan)
* more pam_limits changes (extracted from redhat version) courtesy of
Harald Welte (Bug 436061 - agmorgan)
* configure.in changes to help support non-Linux environments courtesy
diff --git a/modules/pam_tally/Makefile b/modules/pam_tally/Makefile
index 7949b558..1c5106e3 100644
--- a/modules/pam_tally/Makefile
+++ b/modules/pam_tally/Makefile
@@ -67,8 +67,8 @@ $(LIBOBJD): $(LIBSRC)
$(LIBSHARED): $(LIBOBJD)
$(LD_D) -o $@ $(LIBOBJD)
-$(APPLICATION): $(APPOBJD)
- $(CC) $(CFLAGS) -o $@ $< $(LOADLIBES)
+$(APPLICATION): $(APPOBJD) $(TITLE).c
+ $(CC) $(CFLAGS) -o $@ $(APPOBJD) $(LOADLIBES)
endif
@@ -78,8 +78,8 @@ $(LIBOBJS): $(LIBSRC)
$(LIBSTATIC): $(LIBOBJS)
$(LD) -r -o $@ $(LIBOBJS)
-$(APPLICATION): $(APPOBJS)
- $(CC) $(CFLAGS) -o $@ $< $(LOADLIBES)
+$(APPLICATION): $(APPOBJS) $(TITLE).c
+ $(CC) $(CFLAGS) -o $@ $(APPOBJS) $(LOADLIBES)
endif
install: all
@@ -88,7 +88,7 @@ ifdef DYNAMIC
$(INSTALL) -m $(SHLIBMODE) $(LIBSHARED) $(FAKEROOT)$(SECUREDIR)
endif
$(MKDIR) $(FAKEROOT)$(SUPLEMENTED)
-# $(INSTALL) -m $(APPMODE) $(APPLICATION) $(FAKEROOT)$(SUPLEMENTED)
+ $(INSTALL) -m $(APPMODE) $(APPLICATION) $(FAKEROOT)$(SUPLEMENTED)
remove:
rm -f $(FAKEROOT)$(SECUREDIR)/$(TITLE).so
diff --git a/modules/pam_tally/pam_tally.c b/modules/pam_tally/pam_tally.c
index 3d994458..b5bbaba3 100644
--- a/modules/pam_tally/pam_tally.c
+++ b/modules/pam_tally/pam_tally.c
@@ -16,6 +16,7 @@
#include <stdio.h>
#include <string.h>
#include <unistd.h>
+#include <stdlib.h>
#include <stdarg.h>
#include <syslog.h>
#include <pwd.h>
@@ -84,6 +85,7 @@ static void _pam_log(int err, const char *format, ...)
#ifdef MAIN
vfprintf(stderr,format,args);
+ fprintf(stderr,"\n");
#else
openlog(MODULE_NAME, LOG_CONS|LOG_PID, LOG_AUTH);
vsyslog(err, format, args);