summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog36
-rw-r--r--config.h.in3
-rw-r--r--configure.in2
-rw-r--r--libpam_misc/misc_conv.c2
-rw-r--r--libpamc/pamc_converse.c6
-rw-r--r--modules/pam_echo/pam_echo.c6
-rw-r--r--modules/pam_localuser/pam_localuser.c4
-rw-r--r--modules/pam_selinux/pam_selinux.c14
-rw-r--r--modules/pam_selinux/pam_selinux_check.c4
-rw-r--r--modules/pam_unix/pam_unix_passwd.c11
-rw-r--r--modules/pam_unix/support.c2
-rw-r--r--modules/pam_unix/unix_chkpwd.c4
-rw-r--r--po/Linux-PAM.pot2
-rw-r--r--po/cs.po2
-rw-r--r--po/de.po2
-rw-r--r--po/es.po2
-rw-r--r--po/fi.po2
-rw-r--r--po/fr.po2
-rw-r--r--po/hu.po2
-rw-r--r--po/it.po2
-rw-r--r--po/ja.po2
-rw-r--r--po/nb.po2
-rw-r--r--po/pa.po2
-rw-r--r--po/pl.po2
-rw-r--r--po/pt.po2
-rw-r--r--po/pt_BR.po2
-rw-r--r--po/zh_CN.po2
-rw-r--r--po/zh_TW.po2
28 files changed, 77 insertions, 49 deletions
diff --git a/ChangeLog b/ChangeLog
index 9c38b065..84a469f5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,39 @@
+2005-11-24 Dmitry V. Levin <ldv@altlinux.org>
+
+ * configure.in: Do not check for strerror.
+ * libpam_misc/misc_conv.c (read_string): Replace strerror()
+ call with %m specifier.
+ * libpamc/pamc_converse.c (pamc_converse): Likewise.
+ * modules/pam_echo/pam_echo.c (pam_echo): Likewise.
+ * modules/pam_localuser/pam_localuser.c (pam_sm_authenticate):
+ Likewise.
+ * modules/pam_selinux/pam_selinux.c (security_label_tty):
+ Likewise.
+ (security_restorelabel_tty, security_label_tty): Append %m
+ specifier where appropriate.
+ * modules/pam_selinux/pam_selinux_check.c (main): Replace
+ strerror() call with %m specifier.
+ * modules/pam_unix/pam_unix_passwd.c (save_old_password,
+ _update_passwd, _update_shadow): Likewise.
+ * modules/pam_unix/support.c (_unix_run_helper_binary): Likewise.
+ * modules/pam_unix/unix_chkpwd.c (_update_shadow): Likewise.
+ * po/Linux-PAM.pot: Update strings from pam_selinux.
+ * po/cs.po: Likewise.
+ * po/de.po: Likewise.
+ * po/es.po: Likewise.
+ * po/fi.po: Likewise.
+ * po/fr.po: Likewise.
+ * po/hu.po: Likewise.
+ * po/it.po: Likewise.
+ * po/ja.po: Likewise.
+ * po/nb.po: Likewise.
+ * po/pa.po: Likewise.
+ * po/pl.po: Likewise.
+ * po/pt.po: Likewise.
+ * po/pt_BR.po: Likewise.
+ * po/zh_CN.po: Likewise.
+ * po/zh_TW.po: Likewise.
+
2005-11-23 Thorsten Kukuk <kukuk@suse.de>
* modules/pam_xauth/pam_xauth.c (pam_sm_open_session): Introduce
diff --git a/config.h.in b/config.h.in
index edb637ff..95d8b4f7 100644
--- a/config.h.in
+++ b/config.h.in
@@ -123,9 +123,6 @@
/* Define to 1 if you have the `strdup' function. */
#undef HAVE_STRDUP
-/* Define to 1 if you have the `strerror' function. */
-#undef HAVE_STRERROR
-
/* Define to 1 if you have the <strings.h> header file. */
#undef HAVE_STRINGS_H
diff --git a/configure.in b/configure.in
index 288a286a..e950a65e 100644
--- a/configure.in
+++ b/configure.in
@@ -350,7 +350,7 @@ AC_TYPE_GETGROUPS
AC_PROG_GCC_TRADITIONAL
AC_FUNC_MEMCMP
AC_FUNC_VPRINTF
-AC_CHECK_FUNCS(gethostname gettimeofday lckpwdf mkdir select strcspn strdup strerror strspn strstr strtol uname)
+AC_CHECK_FUNCS(gethostname gettimeofday lckpwdf mkdir select strcspn strdup strspn strstr strtol uname)
AC_CHECK_FUNCS(getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r getgrouplist)
diff --git a/libpam_misc/misc_conv.c b/libpam_misc/misc_conv.c
index 52d647ab..e5095d91 100644
--- a/libpam_misc/misc_conv.c
+++ b/libpam_misc/misc_conv.c
@@ -228,7 +228,7 @@ static int read_string(int echo, const char *prompt, char **retstr)
goto cleanexit; /* return malloc()ed "" */
} else if (nc == -1) {
/* Don't loop forever if read() returns -1. */
- D(("error reading input from the user: %s", strerror(errno)));
+ D(("error reading input from the user: %m"));
if (echo) {
fprintf(stderr, "\n");
}
diff --git a/libpamc/pamc_converse.c b/libpamc/pamc_converse.c
index f334c5b9..bb9c6dfd 100644
--- a/libpamc/pamc_converse.c
+++ b/libpamc/pamc_converse.c
@@ -117,7 +117,7 @@ int pamc_converse(pamc_handle_t pch, pamc_bp_t *prompt_p)
case EINTR:
break;
default:
- D(("problem writing to agent: %s", strerror(errno)));
+ D(("problem writing to agent: %m"));
goto pamc_unknown_prompt;
}
} else {
@@ -142,7 +142,7 @@ int pamc_converse(pamc_handle_t pch, pamc_bp_t *prompt_p)
case EINTR:
break;
default:
- D(("problem reading from agent: %s", strerror(errno)));
+ D(("problem reading from agent: %m"));
goto pamc_unknown_prompt;
}
} else if (rval) {
@@ -180,7 +180,7 @@ int pamc_converse(pamc_handle_t pch, pamc_bp_t *prompt_p)
case EINTR:
break;
default:
- D(("problem reading from agent: %s", strerror(errno)));
+ D(("problem reading from agent: %m"));
goto pamc_unknown_prompt;
}
} else if (rval) {
diff --git a/modules/pam_echo/pam_echo.c b/modules/pam_echo/pam_echo.c
index e13b8f94..d378f917 100644
--- a/modules/pam_echo/pam_echo.c
+++ b/modules/pam_echo/pam_echo.c
@@ -179,8 +179,7 @@ pam_echo (pam_handle_t *pamh, int flags, int argc, const char **argv)
if (read (fd, mtmp, st.st_size) == -1)
{
- pam_syslog (pamh, LOG_ERR, "Error while reading %s: %s",
- file, strerror (errno));
+ pam_syslog (pamh, LOG_ERR, "Error while reading %s: %m", file);
free (mtmp);
return PAM_IGNORE;
}
@@ -195,8 +194,7 @@ pam_echo (pam_handle_t *pamh, int flags, int argc, const char **argv)
free (mtmp);
}
else
- pam_syslog (pamh, LOG_ERR, "Cannot open %s: %s",
- file, strerror (errno));
+ pam_syslog (pamh, LOG_ERR, "Cannot open %s: %m", file);
return PAM_IGNORE;
}
diff --git a/modules/pam_localuser/pam_localuser.c b/modules/pam_localuser/pam_localuser.c
index df1c22bf..f99f4421 100644
--- a/modules/pam_localuser/pam_localuser.c
+++ b/modules/pam_localuser/pam_localuser.c
@@ -86,8 +86,8 @@ pam_sm_authenticate (pam_handle_t *pamh, int flags UNUSED,
/* open the file */
fp = fopen(filename, "r");
if(fp == NULL) {
- pam_syslog (pamh, LOG_ERR, "error opening \"%s\": %s",
- filename, strerror(errno));
+ pam_syslog (pamh, LOG_ERR, "error opening \"%s\": %m",
+ filename);
return PAM_SYSTEM_ERR;
}
diff --git a/modules/pam_selinux/pam_selinux.c b/modules/pam_selinux/pam_selinux.c
index 373a38f3..a6ea3e1d 100644
--- a/modules/pam_selinux/pam_selinux.c
+++ b/modules/pam_selinux/pam_selinux.c
@@ -231,7 +231,7 @@ security_restorelabel_tty(const pam_handle_t *pamh,
if (setfilecon(ptr, context) && errno != ENOENT)
{
pam_syslog(pamh, LOG_NOTICE,
- "Warning! Could not relabel %s with %s, not relabeling.\n",
+ "Warning! Could not relabel %s with %s, not relabeling: %m",
ptr, context);
}
}
@@ -257,18 +257,18 @@ security_label_tty(pam_handle_t *pamh, char *tty,
if (getfilecon(ptr, &prev_context) < 0)
{
pam_syslog(pamh, LOG_NOTICE,
- "Warning! Could not get current context for %s, not relabeling.",
+ "Warning! Could not get current context for %s, not relabeling: %m",
ptr);
return NULL;
}
if( security_compute_relabel(usercon,prev_context,SECCLASS_CHR_FILE,
&newdev_context)!=0)
{
- pam_syslog(pamh,LOG_NOTICE,
- "Warning! Could not get new context for %s, not relabeling.",
+ pam_syslog(pamh, LOG_NOTICE,
+ "Warning! Could not get new context for %s, not relabeling: %m",
ptr);
pam_syslog(pamh, LOG_NOTICE,
- "usercon=%s, prev_context=%s\n", usercon, prev_context);
+ "usercon=%s, prev_context=%s", usercon, prev_context);
freecon(prev_context);
return NULL;
}
@@ -276,8 +276,8 @@ security_label_tty(pam_handle_t *pamh, char *tty,
if (status)
{
pam_syslog(pamh, LOG_NOTICE,
- "Warning! Could not relabel %s with %s, not relabeling.%s",
- ptr,newdev_context,strerror(errno));
+ "Warning! Could not relabel %s with %s, not relabeling: %m",
+ ptr,newdev_context);
freecon(prev_context);
prev_context=NULL;
}
diff --git a/modules/pam_selinux/pam_selinux_check.c b/modules/pam_selinux/pam_selinux_check.c
index 73c77fa0..30526d37 100644
--- a/modules/pam_selinux/pam_selinux_check.c
+++ b/modules/pam_selinux/pam_selinux_check.c
@@ -129,10 +129,8 @@ main (int argc, char **argv)
childPid = fork();
if (childPid < 0) {
- int errsv = errno;
-
/* error in fork() */
- fprintf(stderr, _("login: failure forking: %s"), strerror(errsv));
+ fprintf(stderr, _("login: failure forking: %m"));
pam_close_session(pamh, 0);
/* We're done with PAM. Free `pam_handle'. */
pam_end( pamh, PAM_SUCCESS );
diff --git a/modules/pam_unix/pam_unix_passwd.c b/modules/pam_unix/pam_unix_passwd.c
index 09988816..fb96063e 100644
--- a/modules/pam_unix/pam_unix_passwd.c
+++ b/modules/pam_unix/pam_unix_passwd.c
@@ -481,8 +481,7 @@ static int save_old_password(pam_handle_t *pamh,
}
if (fclose(pwfile)) {
- D(("error writing entries to old passwords file: %s\n",
- strerror(errno)));
+ D(("error writing entries to old passwords file: %m"));
err = 1;
}
@@ -585,7 +584,7 @@ static int _update_passwd(pam_handle_t *pamh,
err = 0;
}
if (putpwent(tmpent, pwfile)) {
- D(("error writing entry to password file: %s\n", strerror(errno)));
+ D(("error writing entry to password file: %m"));
err = 1;
break;
}
@@ -594,7 +593,7 @@ static int _update_passwd(pam_handle_t *pamh,
fclose(opwfile);
if (fclose(pwfile)) {
- D(("error writing entries to password file: %s\n", strerror(errno)));
+ D(("error writing entries to password file: %m"));
err = 1;
}
@@ -700,7 +699,7 @@ static int _update_shadow(pam_handle_t *pamh, const char *forwho, char *towhat)
}
if (putspent(stmpent, pwfile)) {
- D(("error writing entry to shadow file: %s\n", strerror(errno)));
+ D(("error writing entry to shadow file: %m"));
err = 1;
break;
}
@@ -710,7 +709,7 @@ static int _update_shadow(pam_handle_t *pamh, const char *forwho, char *towhat)
fclose(opwfile);
if (fclose(pwfile)) {
- D(("error writing entries to shadow file: %s\n", strerror(errno)));
+ D(("error writing entries to shadow file: %m"));
err = 1;
}
diff --git a/modules/pam_unix/support.c b/modules/pam_unix/support.c
index ad949aab..733c25c2 100644
--- a/modules/pam_unix/support.c
+++ b/modules/pam_unix/support.c
@@ -556,7 +556,7 @@ static int _unix_run_helper_binary(pam_handle_t *pamh, const char *passwd,
close(fds[1]);
rc=waitpid(child, &retval, 0); /* wait for helper to complete */
if (rc<0) {
- pam_syslog(pamh, LOG_ERR, "unix_chkpwd waitpid returned %d: %s", rc, strerror(errno));
+ pam_syslog(pamh, LOG_ERR, "unix_chkpwd waitpid returned %d: %m", rc);
retval = PAM_AUTH_ERR;
} else {
retval = WEXITSTATUS(retval);
diff --git a/modules/pam_unix/unix_chkpwd.c b/modules/pam_unix/unix_chkpwd.c
index b817f658..d63387b6 100644
--- a/modules/pam_unix/unix_chkpwd.c
+++ b/modules/pam_unix/unix_chkpwd.c
@@ -383,7 +383,7 @@ static int _update_shadow(const char *forwho)
}
if (putspent(stmpent, pwfile)) {
- D(("error writing entry to shadow file: %s\n", strerror(errno)));
+ D(("error writing entry to shadow file: %m"));
err = 1;
break;
}
@@ -393,7 +393,7 @@ static int _update_shadow(const char *forwho)
fclose(opwfile);
if (fclose(pwfile)) {
- D(("error writing entries to shadow file: %s\n", strerror(errno)));
+ D(("error writing entries to shadow file: %m"));
err = 1;
}
diff --git a/po/Linux-PAM.pot b/po/Linux-PAM.pot
index 1cf8872c..d003f3fe 100644
--- a/po/Linux-PAM.pot
+++ b/po/Linux-PAM.pot
@@ -92,7 +92,7 @@ msgstr ""
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr ""
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/cs.po b/po/cs.po
index 3a6c0727..f4360d98 100644
--- a/po/cs.po
+++ b/po/cs.po
@@ -95,7 +95,7 @@ msgstr "chyba pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "login: chyba forku: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/de.po b/po/de.po
index aade5f06..26226d41 100644
--- a/po/de.po
+++ b/po/de.po
@@ -93,7 +93,7 @@ msgstr "Fehler bei pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "Anmeldung: Fehler bei Abspaltung: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/es.po b/po/es.po
index 6ac7f869..0716300f 100644
--- a/po/es.po
+++ b/po/es.po
@@ -95,7 +95,7 @@ msgstr "error en pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "inicio de sesión: error en horquilla: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/fi.po b/po/fi.po
index 81db9cf4..b29c1622 100644
--- a/po/fi.po
+++ b/po/fi.po
@@ -94,7 +94,7 @@ msgstr "pam_set_item() kutsu epäonnistui\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "sisäänkirjautuminen: virhe haarautumisessa: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/fr.po b/po/fr.po
index 8d8e5852..6d52eec2 100644
--- a/po/fr.po
+++ b/po/fr.po
@@ -92,7 +92,7 @@ msgstr "échec de pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "login : échec d'autoclonage : %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/hu.po b/po/hu.po
index a1fd931f..680cdc22 100644
--- a/po/hu.po
+++ b/po/hu.po
@@ -92,7 +92,7 @@ msgstr "pam_set_item() meghiúsult\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "bejelentkezés: hiba az elágazás közben: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/it.po b/po/it.po
index 0f1320e2..5dcf7857 100644
--- a/po/it.po
+++ b/po/it.po
@@ -93,7 +93,7 @@ msgstr "impossibile pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "login: errore forking: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/ja.po b/po/ja.po
index b5a878d2..ea6a5e10 100644
--- a/po/ja.po
+++ b/po/ja.po
@@ -92,7 +92,7 @@ msgstr "pam_set_item()に失敗しました\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "ログイン: いまいましい失敗: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/nb.po b/po/nb.po
index ea8bf802..1644676c 100644
--- a/po/nb.po
+++ b/po/nb.po
@@ -93,7 +93,7 @@ msgstr "kunne ikke pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "login: feil under forgrening: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/pa.po b/po/pa.po
index bbcb3225..2ed99fd9 100644
--- a/po/pa.po
+++ b/po/pa.po
@@ -95,7 +95,7 @@ msgstr "pam_set_item() ਲਈ ਫੇਲ\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr ""
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/pl.po b/po/pl.po
index c86358a9..f9b36240 100644
--- a/po/pl.po
+++ b/po/pl.po
@@ -92,7 +92,7 @@ msgstr "nieudane pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "login: nieudany fork: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/pt.po b/po/pt.po
index 2d3a9fff..731705d4 100644
--- a/po/pt.po
+++ b/po/pt.po
@@ -93,7 +93,7 @@ msgstr "falha em pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "sessão: falha ao executar o forking: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/pt_BR.po b/po/pt_BR.po
index 765cf1d9..5dba76a6 100644
--- a/po/pt_BR.po
+++ b/po/pt_BR.po
@@ -92,7 +92,7 @@ msgstr "falha em pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "login: falha na bifurcação: %s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/zh_CN.po b/po/zh_CN.po
index 7e3e8fa6..317a480a 100644
--- a/po/zh_CN.po
+++ b/po/zh_CN.po
@@ -91,7 +91,7 @@ msgstr "未能 pam_set_item()\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "登录:故障派生:%s"
#: modules/pam_selinux/pam_selinux.c:102
diff --git a/po/zh_TW.po b/po/zh_TW.po
index d2f86481..5d5fce7a 100644
--- a/po/zh_TW.po
+++ b/po/zh_TW.po
@@ -92,7 +92,7 @@ msgstr "pam_set_item() 失敗\n"
#: modules/pam_selinux/pam_selinux_check.c:135
#, c-format
-msgid "login: failure forking: %s"
+msgid "login: failure forking: %m"
msgstr "登入:失敗的分叉:%s"
#: modules/pam_selinux/pam_selinux.c:102