summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG4
-rwxr-xr-xconfigure5
-rw-r--r--configure.in2
3 files changed, 6 insertions, 5 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 48029a88..873fa13e 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -63,7 +63,9 @@ BerliOS Bugs are marked with (BerliOS #XXXX).
0.79: please submit patches for this section with actual code/doc
patches!
* pam_unix: don't log user unknown failure when he can be properly
- authenticated by another module
+ authenticated by another module (t8m)
+* configure: don't abort if no cracklib dictinaries were found, but
+ warn user that pam_cracklib will not be built.
0.78: Do Nov 18 14:48:36 CET 2004
diff --git a/configure b/configure
index 99b231ab..65687454 100755
--- a/configure
+++ b/configure
@@ -6011,9 +6011,8 @@ for d in $DICT_DIR_CANDIDATES ; do
done
done
if test -z "$CRACKLIB_DICTPATH" ; then
- { { echo "$as_me:$LINENO: error: none found" >&5
-echo "$as_me: error: none found" >&2;}
- { (exit 1); exit 1; }; }
+ { echo "$as_me:$LINENO: WARNING: none found - pam_cracklib will not be built" >&5
+echo "$as_me: WARNING: none found - pam_cracklib will not be built" >&2;}
else
echo "$as_me:$LINENO: result: $CRACKLIB_DICTPATH" >&5
echo "${ECHO_T}$CRACKLIB_DICTPATH" >&6
diff --git a/configure.in b/configure.in
index 50ce85df..40f74b51 100644
--- a/configure.in
+++ b/configure.in
@@ -278,7 +278,7 @@ for d in $DICT_DIR_CANDIDATES ; do
done
done
if test -z "$CRACKLIB_DICTPATH" ; then
- AC_MSG_ERROR(none found)
+ AC_MSG_WARN([none found - pam_cracklib will not be built])
else
AC_MSG_RESULT($CRACKLIB_DICTPATH)
fi