summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 226bb03d..b0c0e1ca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -49,8 +49,10 @@ override_dh_installman:
# dh_fixperms doesn't want
override_dh_fixperms:
dh_fixperms
+ifeq (,$(findstring -i, $(DH_INTERNAL_OPTIONS)))
chgrp shadow $(d)/libpam-modules/sbin/unix_chkpwd
chmod 02755 $(d)/libpam-modules/sbin/unix_chkpwd
+endif
# ideally, dh_makeshlibs could compute this from the symbols file; or we
# could drop it since anyone building against this package should have a