summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches-applied/series1
-rw-r--r--debian/patches-applied/sys-types-include.patch21
3 files changed, 25 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7f5b63d7..1b1ba96c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,9 @@ pam (1.1.0-5) UNRELEASED; urgency=low
* Updated debconf translations:
- French, thanks to Jean-Baka Domelevo Entfellner <domelevo@gmail.com>
(closes: #547039)
+ * debian/patches/sys-types-include.patch: fix pam_modutil.h so that it can
+ be included directly, without having to include sys/types.h first.
+ Closes: #556203.
-- Steve Langasek <vorlon@debian.org> Wed, 16 Sep 2009 15:25:40 -0700
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index dde1da8f..bf13a538 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -22,3 +22,4 @@ update-motd
fix-man-crud
namespace_with_awk_not_gawk
pam_securetty_tty_check_before_user_check
+sys-types-include.patch
diff --git a/debian/patches-applied/sys-types-include.patch b/debian/patches-applied/sys-types-include.patch
new file mode 100644
index 00000000..fbcb70d3
--- /dev/null
+++ b/debian/patches-applied/sys-types-include.patch
@@ -0,0 +1,21 @@
+Patch for Debian bug #556203
+
+pam_modutil.h should include sys/types.h, so that it stands alone without
+callers having to do additional busywork.
+
+Authors: Russ Allbery <rra@debian.org>
+
+Upstream status: not yet submitted
+
+Index: pam.debian/libpam/include/security/pam_modutil.h
+===================================================================
+--- pam.debian.orig/libpam/include/security/pam_modutil.h
++++ pam.debian/libpam/include/security/pam_modutil.h
+@@ -51,6 +51,7 @@
+ extern "C" {
+ #endif
+
++#include <sys/types.h>
+ #include <security/_pam_types.h>
+
+ extern struct passwd * PAM_NONNULL((1,2))