summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog5
-rw-r--r--libpam/Makefile.am11
-rw-r--r--modules/pam_tally/Makefile.am5
-rw-r--r--modules/pam_unix/Makefile.am9
4 files changed, 19 insertions, 11 deletions
diff --git a/ChangeLog b/ChangeLog
index 53652788..94a15488 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,10 @@
2006-12-18 Thorsten Kukuk <kukuk@thkukuk.de>
+ * configure.in: Add AM_PROG_CC_C_O.
+ * libpam/Makefile.am: Add content of AM_LDFLAGS to *_LDFLAGS.
+ * modules/pam_tally/Makefile.am: Likewise.
+ * modules/pam_unix/Makefile.am: Likewise.
+
* modules/pam_stress/pam_stress.c (pam_sm_chauthtok): Fix
localisation of message printed to user.
* po/de.po: Adjust translation.
diff --git a/libpam/Makefile.am b/libpam/Makefile.am
index 8c603efe..e96d6df8 100644
--- a/libpam/Makefile.am
+++ b/libpam/Makefile.am
@@ -8,19 +8,20 @@ if HAVE_LIBSELINUX
AM_CFLAGS += -D"WITH_SELINUX"
endif
-AM_LDFLAGS = $(LIBPRELUDE_LIBS) @LIBDL@
-
CLEANFILES = *~
EXTRA_DIST = libpam.map
-include_HEADERS = $(addprefix include/security/, _pam_compat.h _pam_macros.h _pam_types.h \
- pam_appl.h pam_modules.h pam_ext.h pam_modutil.h)
+include_HEADERS = include/security/_pam_compat.h \
+ include/security/_pam_macros.h include/security/_pam_types.h \
+ include/security/pam_appl.h include/security/pam_modules.h \
+ include/security/pam_ext.h include/security/pam_modutil.h
noinst_HEADERS = pam_prelude.h pam_private.h pam_tokens.h \
pam_modutil_private.h pam_static_modules.h
-libpam_la_LDFLAGS = -no-undefined -version-info 81:6:81 @LIBAUDIT@
+libpam_la_LDFLAGS = -no-undefined -version-info 81:6:81 \
+ @LIBAUDIT@ $(LIBPRELUDE_LIBS) @LIBDL@
if STATIC_MODULES
libpam_la_LDFLAGS += `ls ../modules/pam_*/*.lo` \
@LIBDB@ @LIBCRYPT@ @LIBNSL@ @LIBCRACK@ -lutil
diff --git a/modules/pam_tally/Makefile.am b/modules/pam_tally/Makefile.am
index 72a70401..ffb88886 100644
--- a/modules/pam_tally/Makefile.am
+++ b/modules/pam_tally/Makefile.am
@@ -17,9 +17,9 @@ secureconfdir = $(SCONFIGDIR)
noinst_HEADERS = faillog.h
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
-AM_LDFLAGS = -L$(top_builddir)/libpam -lpam
-pam_tally_la_LDFLAGS = -no-undefined -avoid-version -module
+pam_tally_la_LDFLAGS = -no-undefined -avoid-version -module \
+ -L$(top_builddir)/libpam -lpam
if HAVE_VERSIONING
pam_tally_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
@@ -28,6 +28,7 @@ securelib_LTLIBRARIES = pam_tally.la
sbin_PROGRAMS = pam_tally
pam_tally_SOURCES = pam_tally_app.c
+pam_tally_LDFLAGS = -L$(top_builddir)/libpam -lpam
if ENABLE_REGENERATE_MAN
noinst_DATA = README
diff --git a/modules/pam_unix/Makefile.am b/modules/pam_unix/Makefile.am
index 5f60d98b..83b6c0b3 100644
--- a/modules/pam_unix/Makefile.am
+++ b/modules/pam_unix/Makefile.am
@@ -18,8 +18,6 @@ secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
-DCHKPWD_HELPER=\"$(sbindir)/unix_chkpwd\"
-AM_LDFLAGS = -L$(top_builddir)/libpam -lpam @LIBCRYPT@ @LIBSELINUX@
-
if HAVE_LIBSELINUX
AM_CFLAGS += -D"WITH_SELINUX"
endif
@@ -28,7 +26,8 @@ if HAVE_LIBCRACK
endif
pam_unix_la_LDFLAGS = -no-undefined -avoid-version -module \
- @LIBCRACK@ @LIBNSL@
+ @LIBCRACK@ @LIBNSL@ -L$(top_builddir)/libpam -lpam \
+ @LIBCRYPT@ @LIBSELINUX@
if HAVE_VERSIONING
pam_unix_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
@@ -47,10 +46,12 @@ pam_unix_la_SOURCES = bigcrypt.c pam_unix_acct.c \
bigcrypt_SOURCES = bigcrypt.c bigcrypt_main.c
bigcrypt_CFLAGS = $(AM_CFLAGS)
+bigcrypt_LDFLAGS = @LIBCRYPT@
unix_chkpwd_SOURCES = unix_chkpwd.c md5_good.c md5_broken.c bigcrypt.c
unix_chkpwd_CFLAGS = $(AM_CFLAGS) @PIE_CFLAGS@
-unix_chkpwd_LDFLAGS = @PIE_LDFLAGS@
+unix_chkpwd_LDFLAGS = @PIE_LDFLAGS@ -L$(top_builddir)/libpam -lpam \
+ @LIBCRYPT@ @LIBSELINUX@
if ENABLE_REGENERATE_MAN
noinst_DATA = README