summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog13
1 files changed, 12 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 6477d520..34a3d53a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,9 +1,20 @@
2006-01-22 Thorsten Kukuk <kukuk@thkukuk.de>
+ * modules/pam_succeed_if/pam_succeed_if.c (pam_sm_acct_mgmt):
+ Add support for static modules.
+ * modules/pam_xauth/pam_xauth.c: Likewise.
+
+ * libpam/pam_handlers.c (_pam_add_handler): Add pamh to
+ _pam_open_static_handler call.
+
+ * libpam/pam_static.c (_pam_open_static_handler): Add pamh
+ as argument.
+ * libpam/pam_private.h: Adjust prototype.
+
* configure.in: Don't define PAM_DYNAMIC.
* libpam/pam_handlers.c: Get ride of PAM_DYNAMIC, don't
include pam_dynamic.h
- * libpam/pam_dynamic.c: Don't include pam_dynamic.h,
+ * libpam/pam_dynamic.c: Don't include pam_dynamic.h,
exclude functions if we compile with PAM_STATIC.
* libpam/pam_dynamic.h: Remove.
* libpam/pam_private.h: Add function prototypes from pam_dynamic.h.