summaryrefslogtreecommitdiff
path: root/Linux-PAM/modules/pam_limits/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Linux-PAM/modules/pam_limits/Makefile')
-rw-r--r--Linux-PAM/modules/pam_limits/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/Linux-PAM/modules/pam_limits/Makefile b/Linux-PAM/modules/pam_limits/Makefile
new file mode 100644
index 00000000..b7462851
--- /dev/null
+++ b/Linux-PAM/modules/pam_limits/Makefile
@@ -0,0 +1,31 @@
+#
+# $Id: Makefile,v 1.1.1.1 2001/04/29 04:17:22 hartmans Exp $
+#
+# This Makefile controls a build process of $(TITLE) module for
+# Linux-PAM. You should not modify this Makefile (unless you know
+# what you are doing!).
+#
+
+include ../../Make.Rules
+
+TITLE=pam_limits
+
+ifeq ($(OS),linux)
+
+LOCAL_CONFILE=./limits.skel
+INSTALLED_CONFILE=$(SCONFIGD)/limits.conf
+
+DEFS=-DDEFAULT_CONF_FILE=\"$(INSTALLED_CONFILE)\"
+CFLAGS += $(DEFS)
+
+MODULE_SIMPLE_INSTALL=bash -f ../install_conf "$(FAKEROOT)" "$(SCONFIGD)" "$(INSTALLED_CONFILE)" "$(TITLE)" "$(LOCAL_CONFILE)"
+MODULE_SIMPLE_REMOVE=rm -f $(FAKEROOT)$(INSTALLED_CONFILE)
+MODULE_SIMPLE_CLEAN=rm -f ./.ignore_age
+
+include ../Simple.Rules
+
+else
+
+include ../dont_makefile
+
+endif