summaryrefslogtreecommitdiff
path: root/Linux-PAM/modules/pam_userdb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Linux-PAM/modules/pam_userdb/Makefile')
-rw-r--r--Linux-PAM/modules/pam_userdb/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/Linux-PAM/modules/pam_userdb/Makefile b/Linux-PAM/modules/pam_userdb/Makefile
new file mode 100644
index 00000000..bb774ddb
--- /dev/null
+++ b/Linux-PAM/modules/pam_userdb/Makefile
@@ -0,0 +1,37 @@
+#
+# This Makefile controls a build process of $(TITLE) module for
+# Linux-PAM. You should not modify this Makefile (unless you know
+# what you are doing!).
+
+# $Id: Makefile,v 1.1.1.2 2002/09/15 20:09:02 hartmans Exp $
+# Created by Cristian Gafton <gafton@redhat.com>
+
+include ../../Make.Rules
+
+TITLE=pam_userdb
+
+ifeq ($(HAVE_NDBM_H),yes)
+ WHICH_DB=ndbm
+ ifeq ($(HAVE_LIBNDBM),yes)
+ MODULE_SIMPLE_EXTRALIBS = -lndbm
+ endif
+else
+ifeq ($(HAVE_LIBDB),yes)
+ WHICH_DB=db
+ MODULE_SIMPLE_EXTRALIBS = -ldb
+else
+ WHICH_DB=none
+endif
+endif
+
+ifeq ($(WHICH_DB),none)
+
+include ../dont_makefile
+
+else
+
+MODULE_SIMPLE_EXTRAFILES = conv
+
+include ../Simple.Rules
+
+endif