summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 26e0f468..2f57fff7 100644
--- a/Makefile
+++ b/Makefile
@@ -42,12 +42,14 @@ Make.Rules: configure Make.Rules.in _pam_aconf.h.in
@echo XXX - by hand, with the options you want.
./configure
+_pam_aconf.h: Make.Rules
+
configure: configure.in
- @$(MAKE) distclean
@echo
- @echo You do not appear to have a ./configure file.
+ @echo You do not appear to have an up-to-date ./configure file.
@echo Please run autoconf, and then ./configure [..options..]
@echo
+ @rm -f configure
@exit 1
$(THINGSTOMAKE): _pam_aconf.h prep