summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 4c6d1604..6fad4e11 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(conf/pam_conv1/pam_conv.y)
+AC_INIT(conf/pam_conv1/pam_conv_y.y)
AM_INIT_AUTOMAKE("Linux-PAM", 0.99.5.0)
AM_CONFIG_HEADER(config.h)
AC_CANONICAL_HOST
@@ -223,12 +223,12 @@ AC_ARG_ENABLE([debug],
AC_SUBST(WITH_DEBUG)
AC_ARG_ENABLE(securedir,
-[ --enable-securedir=<path to location of PAMs> [default \$libdir/security]],
+ AC_HELP_STRING([--enable-securedir=DIR],[path to location of PAMs @<:@default=$libdir/security@:>@]),
SECUREDIR=$enableval, SECUREDIR=$libdir/security)
AC_SUBST(SECUREDIR)
AC_ARG_ENABLE([isadir],
- AC_HELP_STRING([--enable-isadir=DIR],[path to arch-specific module files [default ../../`basename $libdir`/security]]),
+ AC_HELP_STRING([--enable-isadir=DIR],[path to arch-specific module files @<:@default=../../(basename of $libdir)/security@:>@]),
ISA=$enableval,
ISA=../../`basename $libdir`/security)
unset mylibdirbase
@@ -236,25 +236,25 @@ AC_DEFINE_UNQUOTED(_PAM_ISA,"$ISA",[Define to the path, relative to SECUREDIR, w
AC_MSG_RESULT([Defining \$ISA to "$ISA"])
AC_ARG_ENABLE(sconfigdir,
-[ --enable-sconfigdir=<path to module conf files> [default \$sysconfdir/security]],
+ AC_HELP_STRING([--enable-sconfigdir=DIR],[path to module conf files @<:@default=$sysconfdir/security@:>@]),
SCONFIGDIR=$enableval, SCONFIGDIR=$sysconfdir/security)
AC_SUBST(SCONFIGDIR)
AC_ARG_ENABLE(docdir,
-[ --enable-docdir=<path to store documentation in - /usr/share/doc/pam>],
- DOCDIR=$enableval, DOCDIR=/usr/share/doc/pam)
+ AC_HELP_STRING([--enable-docdir=DIR],[path to documentation @<:@default=$datadir/doc/pam@:>@]),
+ DOCDIR=$enableval, DOCDIR=$datadir/doc/pam)
AC_SUBST(DOCDIR)
AC_ARG_ENABLE(pamlocking,
-[ --enable-pamlocking configure libpam to observe a global authentication lock],
+ AC_HELP_STRING([--enable-pamlocking],[configure libpam to observe a global authentication lock]),
WITH_PAMLOCKING=yes ; AC_DEFINE([PAM_LOCKING],,
[libpam should observe a global authentication lock]),
WITH_PAMLOCKING=no)
AC_SUBST(WITH_PAMLOCKING)
AC_ARG_ENABLE(read-both-confs,
-[ --enable-read-both-confs read both /etc/pam.d and /etc/pam.conf files],
+ AC_HELP_STRING([--enable-read-both-confs],[read both /etc/pam.d and /etc/pam.conf files]),
AC_DEFINE([PAM_READ_BOTH_CONFS],,
[read both /etc/pam.d and /etc/pam.conf files]))
AC_SUBST(PAM_READ_BOTH_CONFS)