summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2597802f..6797e2fe 100644
--- a/configure.in
+++ b/configure.in
@@ -144,6 +144,15 @@ AC_MSG_CHECKING([for CC_FOR_BUILD])
AC_MSG_RESULT([$CC_FOR_BUILD])
AC_SUBST(CC_FOR_BUILD)
+if test "x${BUILD_CPPFLAGS+set}" != "xset" ; then
+ if test "x$cross_compiling" = "xyes" ; then
+ BUILD_CPPFLAGS=
+ else
+ BUILD_CPPFLAGS=${CPPFLAGS}
+ fi
+fi
+AC_SUBST(BUILD_CPPFLAGS)
+
if test "x${BUILD_CFLAGS+set}" != "xset" ; then
if test "x$cross_compiling" = "xyes" ; then
BUILD_CFLAGS=