summaryrefslogtreecommitdiff
path: root/debian/patches-applied/055_pam_unix_nullok_secure
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches-applied/055_pam_unix_nullok_secure')
-rw-r--r--debian/patches-applied/055_pam_unix_nullok_secure54
1 files changed, 27 insertions, 27 deletions
diff --git a/debian/patches-applied/055_pam_unix_nullok_secure b/debian/patches-applied/055_pam_unix_nullok_secure
index c30b2cf6..f0b0a3d2 100644
--- a/debian/patches-applied/055_pam_unix_nullok_secure
+++ b/debian/patches-applied/055_pam_unix_nullok_secure
@@ -7,14 +7,14 @@ Authors: Sam Hartman <hartmans@debian.org>,
Upstream status: not yet submitted
-Index: pam-debian/modules/pam_unix/support.c
+Index: pam.debian/modules/pam_unix/support.c
===================================================================
---- pam-debian.orig/modules/pam_unix/support.c 2011-10-10 16:25:36.000000000 -0700
-+++ pam-debian/modules/pam_unix/support.c 2011-10-10 17:51:23.078413270 -0700
+--- pam.debian.orig/modules/pam_unix/support.c
++++ pam.debian/modules/pam_unix/support.c
@@ -84,14 +84,22 @@
/* now parse the arguments to this module */
- while (argc-- > 0) {
+ for (; argc-- > 0; ++argv) {
- int j;
+ int j, sl;
@@ -38,7 +38,7 @@ Index: pam-debian/modules/pam_unix/support.c
}
}
-@@ -448,6 +456,7 @@
+@@ -461,6 +469,7 @@
child = fork();
if (child == 0) {
int i=0;
@@ -46,7 +46,7 @@ Index: pam-debian/modules/pam_unix/support.c
struct rlimit rlim;
static char *envp[] = { NULL };
char *args[] = { NULL, NULL, NULL, NULL };
-@@ -475,7 +484,18 @@
+@@ -488,7 +497,18 @@
/* exec binary helper */
args[0] = strdup(CHKPWD_HELPER);
args[1] = x_strdup(user);
@@ -66,7 +66,7 @@ Index: pam-debian/modules/pam_unix/support.c
args[2]=strdup("nullok");
} else {
args[2]=strdup("nonull");
-@@ -556,6 +576,17 @@
+@@ -567,6 +587,17 @@
if (on(UNIX__NONULL, ctrl))
return 0; /* will fail but don't let on yet */
@@ -84,7 +84,7 @@ Index: pam-debian/modules/pam_unix/support.c
/* UNIX passwords area */
retval = get_pwd_hash(pamh, name, &pwd, &salt);
-@@ -642,7 +673,8 @@
+@@ -653,7 +684,8 @@
}
}
} else {
@@ -94,10 +94,10 @@ Index: pam-debian/modules/pam_unix/support.c
}
if (retval == PAM_SUCCESS) {
-Index: pam-debian/modules/pam_unix/support.h
+Index: pam.debian/modules/pam_unix/support.h
===================================================================
---- pam-debian.orig/modules/pam_unix/support.h 2011-10-10 16:24:49.000000000 -0700
-+++ pam-debian/modules/pam_unix/support.h 2011-10-10 17:51:23.078413270 -0700
+--- pam.debian.orig/modules/pam_unix/support.h
++++ pam.debian/modules/pam_unix/support.h
@@ -91,8 +91,9 @@
#define UNIX_BLOWFISH_PASS 26 /* new password hashes will use blowfish */
#define UNIX_MIN_PASS_LEN 27 /* min length for password */
@@ -136,24 +136,24 @@ Index: pam-debian/modules/pam_unix/support.h
extern int _unix_run_verify_binary(pam_handle_t *pamh,
unsigned int ctrl, const char *user, int *daysleft);
#endif /* _PAM_UNIX_SUPPORT_H */
-Index: pam-debian/modules/pam_unix/Makefile.am
+Index: pam.debian/modules/pam_unix/Makefile.am
===================================================================
---- pam-debian.orig/modules/pam_unix/Makefile.am 2011-10-10 16:24:49.000000000 -0700
-+++ pam-debian/modules/pam_unix/Makefile.am 2011-10-10 17:51:23.078413270 -0700
-@@ -29,7 +29,8 @@
+--- pam.debian.orig/modules/pam_unix/Makefile.am
++++ pam.debian/modules/pam_unix/Makefile.am
+@@ -30,7 +30,8 @@
pam_unix_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
- pam_unix_la_LIBADD = @LIBNSL@ -L$(top_builddir)/libpam -lpam \
-- @LIBCRYPT@ @LIBSELINUX@
-+ @LIBCRYPT@ @LIBSELINUX@ \
+ pam_unix_la_LIBADD = -L$(top_builddir)/libpam -lpam \
+- @LIBCRYPT@ @LIBSELINUX@ $(NIS_LIBS)
++ @LIBCRYPT@ @LIBSELINUX@ $(NIS_LIBS) \
+ ../pam_securetty/tty_secure.lo
securelib_LTLIBRARIES = pam_unix.la
-Index: pam-debian/modules/pam_unix/README
+Index: pam.debian/modules/pam_unix/README
===================================================================
---- pam-debian.orig/modules/pam_unix/README 2011-10-10 16:21:55.000000000 -0700
-+++ pam-debian/modules/pam_unix/README 2011-10-10 17:51:23.078413270 -0700
+--- pam.debian.orig/modules/pam_unix/README
++++ pam.debian/modules/pam_unix/README
@@ -57,7 +57,16 @@
The default action of this module is to not permit the user access to a
@@ -172,10 +172,10 @@ Index: pam-debian/modules/pam_unix/README
try_first_pass
-Index: pam-debian/modules/pam_unix/pam_unix.8
+Index: pam.debian/modules/pam_unix/pam_unix.8
===================================================================
---- pam-debian.orig/modules/pam_unix/pam_unix.8 2011-10-10 16:24:49.000000000 -0700
-+++ pam-debian/modules/pam_unix/pam_unix.8 2011-10-10 17:51:23.078413270 -0700
+--- pam.debian.orig/modules/pam_unix/pam_unix.8
++++ pam.debian/modules/pam_unix/pam_unix.8
@@ -79,7 +79,14 @@
.RS 4
The default action of this module is to not permit the user access to a service if their official password is blank\&. The
@@ -192,10 +192,10 @@ Index: pam-debian/modules/pam_unix/pam_unix.8
.RE
.PP
\fBtry_first_pass\fR
-Index: pam-debian/modules/pam_unix/pam_unix.8.xml
+Index: pam.debian/modules/pam_unix/pam_unix.8.xml
===================================================================
---- pam-debian.orig/modules/pam_unix/pam_unix.8.xml 2011-10-10 16:24:49.000000000 -0700
-+++ pam-debian/modules/pam_unix/pam_unix.8.xml 2011-10-10 17:51:23.078413270 -0700
+--- pam.debian.orig/modules/pam_unix/pam_unix.8.xml
++++ pam.debian/modules/pam_unix/pam_unix.8.xml
@@ -135,7 +135,24 @@
<para>
The default action of this module is to not permit the