summaryrefslogtreecommitdiff
path: root/debian/patches-applied/055_pam_unix_nullok_secure
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches-applied/055_pam_unix_nullok_secure')
-rw-r--r--debian/patches-applied/055_pam_unix_nullok_secure67
1 files changed, 33 insertions, 34 deletions
diff --git a/debian/patches-applied/055_pam_unix_nullok_secure b/debian/patches-applied/055_pam_unix_nullok_secure
index 98e1909d..e62c20d1 100644
--- a/debian/patches-applied/055_pam_unix_nullok_secure
+++ b/debian/patches-applied/055_pam_unix_nullok_secure
@@ -7,11 +7,11 @@ Authors: Sam Hartman <hartmans@debian.org>,
Upstream status: not yet submitted
-Index: Linux-PAM/modules/pam_unix/support.c
+Index: pam.debian/modules/pam_unix/support.c
===================================================================
---- Linux-PAM/modules/pam_unix/support.c.orig
-+++ Linux-PAM/modules/pam_unix/support.c
-@@ -87,15 +87,22 @@
+--- pam.debian.orig/modules/pam_unix/support.c
++++ pam.debian/modules/pam_unix/support.c
+@@ -84,15 +84,22 @@
/* now parse the arguments to this module */
while (argc-- > 0) {
@@ -39,7 +39,7 @@ Index: Linux-PAM/modules/pam_unix/support.c
}
}
-@@ -472,6 +479,17 @@
+@@ -469,6 +476,17 @@
if (salt)
_pam_delete(salt);
@@ -57,8 +57,8 @@ Index: Linux-PAM/modules/pam_unix/support.c
return retval;
}
-@@ -692,7 +710,7 @@
- int salt_len = strlen(salt);
+@@ -689,7 +707,7 @@
+ size_t salt_len = strlen(salt);
if (!salt_len) {
/* the stored password is NULL */
- if (off(UNIX__NONULL, ctrl)) {/* this means we've succeeded */
@@ -66,10 +66,10 @@ Index: Linux-PAM/modules/pam_unix/support.c
D(("user has empty password - access granted"));
retval = PAM_SUCCESS;
} else {
-Index: Linux-PAM/modules/pam_unix/support.h
+Index: pam.debian/modules/pam_unix/support.h
===================================================================
---- Linux-PAM/modules/pam_unix/support.h.orig
-+++ Linux-PAM/modules/pam_unix/support.h
+--- pam.debian.orig/modules/pam_unix/support.h
++++ pam.debian/modules/pam_unix/support.h
@@ -87,8 +87,9 @@
#define UNIX_MAX_PASS_LEN 23 /* internal, for compatibility only */
#define UNIX_MIN_PASS_LEN 24 /* Min length for password */
@@ -98,7 +98,7 @@ Index: Linux-PAM/modules/pam_unix/support.h
};
#define UNIX_DEFAULTS (unix_args[UNIX__NONULL].flag)
-@@ -157,6 +159,9 @@
+@@ -157,5 +159,8 @@
,const void **pass);
extern int _unix_shadowed(const struct passwd *pwd);
@@ -106,26 +106,25 @@ Index: Linux-PAM/modules/pam_unix/support.h
+ const char *uttyname);
+
extern struct spwd *_unix_run_verify_binary(pam_handle_t *pamh, unsigned int ctrl, const char *user);
-
- extern unsigned int pass_min_len;
-Index: Linux-PAM/modules/pam_unix/Makefile.am
+ #endif /* _PAM_UNIX_SUPPORT_H */
+Index: pam.debian/modules/pam_unix/Makefile.am
===================================================================
---- Linux-PAM/modules/pam_unix/Makefile.am.orig
-+++ Linux-PAM/modules/pam_unix/Makefile.am
-@@ -44,6 +44,9 @@
- pam_unix_auth.c pam_unix_passwd.c pam_unix_sess.c support.c \
- yppasswd_xdr.c md5_good.c md5_broken.c obscure.c
-
-+pam_unix_la_LIBADD = \
+--- pam.debian.orig/modules/pam_unix/Makefile.am
++++ pam.debian/modules/pam_unix/Makefile.am
+@@ -30,7 +30,8 @@
+ pam_unix_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
+ endif
+ pam_unix_la_LIBADD = @LIBCRACK@ @LIBNSL@ -L$(top_builddir)/libpam -lpam \
+- @LIBCRYPT@ @LIBSELINUX@
++ @LIBCRYPT@ @LIBSELINUX@ \
+ ../pam_securetty/tty_secure.lo
-+
- bigcrypt_SOURCES = bigcrypt.c bigcrypt_main.c
- bigcrypt_CFLAGS = $(AM_CFLAGS)
- bigcrypt_LDFLAGS = @LIBCRYPT@
-Index: Linux-PAM/modules/pam_unix/README
+
+ securelib_LTLIBRARIES = pam_unix.la
+
+Index: pam.debian/modules/pam_unix/README
===================================================================
---- Linux-PAM/modules/pam_unix/README.orig
-+++ Linux-PAM/modules/pam_unix/README
+--- pam.debian.orig/modules/pam_unix/README
++++ pam.debian/modules/pam_unix/README
@@ -57,7 +57,16 @@
The default action of this module is to not permit the user access to a
@@ -144,10 +143,10 @@ Index: Linux-PAM/modules/pam_unix/README
try_first_pass
-Index: Linux-PAM/modules/pam_unix/pam_unix.8
+Index: pam.debian/modules/pam_unix/pam_unix.8
===================================================================
---- Linux-PAM/modules/pam_unix/pam_unix.8.orig
-+++ Linux-PAM/modules/pam_unix/pam_unix.8
+--- pam.debian.orig/modules/pam_unix/pam_unix.8
++++ pam.debian/modules/pam_unix/pam_unix.8
@@ -62,7 +62,14 @@
.RS 4
The default action of this module is to not permit the user access to a service if their official password is blank\. The
@@ -164,10 +163,10 @@ Index: Linux-PAM/modules/pam_unix/pam_unix.8
.RE
.PP
\fBtry_first_pass\fR
-Index: Linux-PAM/modules/pam_unix/pam_unix.8.xml
+Index: pam.debian/modules/pam_unix/pam_unix.8.xml
===================================================================
---- Linux-PAM/modules/pam_unix/pam_unix.8.xml.orig
-+++ Linux-PAM/modules/pam_unix/pam_unix.8.xml
+--- pam.debian.orig/modules/pam_unix/pam_unix.8.xml
++++ pam.debian/modules/pam_unix/pam_unix.8.xml
@@ -135,7 +135,24 @@
<para>
The default action of this module is to not permit the