summaryrefslogtreecommitdiff
path: root/debian/patches-applied/055_pam_unix_nullok_secure
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches-applied/055_pam_unix_nullok_secure')
-rw-r--r--debian/patches-applied/055_pam_unix_nullok_secure24
1 files changed, 12 insertions, 12 deletions
diff --git a/debian/patches-applied/055_pam_unix_nullok_secure b/debian/patches-applied/055_pam_unix_nullok_secure
index 1fd1bf12..27415915 100644
--- a/debian/patches-applied/055_pam_unix_nullok_secure
+++ b/debian/patches-applied/055_pam_unix_nullok_secure
@@ -11,7 +11,7 @@ Index: pam.deb/modules/pam_unix/support.c
===================================================================
--- pam.deb.orig/modules/pam_unix/support.c
+++ pam.deb/modules/pam_unix/support.c
-@@ -83,15 +83,22 @@
+@@ -85,15 +85,22 @@
/* now parse the arguments to this module */
while (argc-- > 0) {
@@ -39,7 +39,7 @@ Index: pam.deb/modules/pam_unix/support.c
}
}
-@@ -443,6 +450,7 @@
+@@ -449,6 +456,7 @@
child = fork();
if (child == 0) {
int i=0;
@@ -47,7 +47,7 @@ Index: pam.deb/modules/pam_unix/support.c
struct rlimit rlim;
static char *envp[] = { NULL };
char *args[] = { NULL, NULL, NULL, NULL };
-@@ -470,7 +478,18 @@
+@@ -476,7 +484,18 @@
/* exec binary helper */
args[0] = strdup(CHKPWD_HELPER);
args[1] = x_strdup(user);
@@ -67,7 +67,7 @@ Index: pam.deb/modules/pam_unix/support.c
args[2]=strdup("nullok");
} else {
args[2]=strdup("nonull");
-@@ -551,6 +570,17 @@
+@@ -557,6 +576,17 @@
if (on(UNIX__NONULL, ctrl))
return 0; /* will fail but don't let on yet */
@@ -85,7 +85,7 @@ Index: pam.deb/modules/pam_unix/support.c
/* UNIX passwords area */
retval = get_pwd_hash(pamh, name, &pwd, &salt);
-@@ -637,7 +667,8 @@
+@@ -643,7 +673,8 @@
}
}
} else {
@@ -108,9 +108,9 @@ Index: pam.deb/modules/pam_unix/support.h
-#define UNIX_CTRLS_ 30 /* number of ctrl arguments defined */
+#define UNIX_CTRLS_ 31 /* number of ctrl arguments defined */
- static const UNIX_Ctrls unix_args[UNIX_CTRLS_] =
- {
-@@ -109,7 +110,7 @@
+ #define UNIX_HASH_MASK (UNIX_MD5_PASS|UNIX_BIGCRYPT|UNIX_SHA256_PASS|UNIX_SHA512_PASS|UNIX_BLOWFISH_PASS)
+
+@@ -111,7 +112,7 @@
/* UNIX_NOT_SET_PASS */ {"not_set_pass", _ALL_ON_, 0x40},
/* UNIX__PRELIM */ {NULL, _ALL_ON_^(0x180), 0x80},
/* UNIX__UPDATE */ {NULL, _ALL_ON_^(0x180), 0x100},
@@ -119,7 +119,7 @@ Index: pam.deb/modules/pam_unix/support.h
/* UNIX__QUIET */ {NULL, _ALL_ON_, 0x400},
/* UNIX_USE_AUTHTOK */ {"use_authtok", _ALL_ON_, 0x800},
/* UNIX_SHADOW */ {"shadow", _ALL_ON_, 0x1000},
-@@ -130,6 +131,7 @@
+@@ -132,6 +133,7 @@
/* UNIX_MAX_PASS_LEN */ {"max=", _ALL_ON_, 0},
/* UNIX_MIN_PASS_LEN */ {"min=", _ALL_ON_, 0x4000000},
/* UNIX_OBSCURE_CHECKS */ {"obscure", _ALL_ON_, 0x8000000},
@@ -127,7 +127,7 @@ Index: pam.deb/modules/pam_unix/support.h
};
#define UNIX_DEFAULTS (unix_args[UNIX__NONULL].flag)
-@@ -165,6 +167,9 @@
+@@ -167,6 +169,9 @@
,const char *data_name
,const void **pass);
@@ -141,7 +141,7 @@ Index: pam.deb/modules/pam_unix/Makefile.am
===================================================================
--- pam.deb.orig/modules/pam_unix/Makefile.am
+++ pam.deb/modules/pam_unix/Makefile.am
-@@ -28,7 +28,8 @@
+@@ -29,7 +29,8 @@
pam_unix_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
pam_unix_la_LIBADD = @LIBNSL@ -L$(top_builddir)/libpam -lpam \
@@ -177,7 +177,7 @@ Index: pam.deb/modules/pam_unix/pam_unix.8
===================================================================
--- pam.deb.orig/modules/pam_unix/pam_unix.8
+++ pam.deb/modules/pam_unix/pam_unix.8
-@@ -62,7 +62,14 @@
+@@ -218,7 +218,14 @@
.RS 4
The default action of this module is to not permit the user access to a service if their official password is blank\&. The
\fBnullok\fR