summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 10 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index d8cc37ed..7f4ed318 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,8 @@ dl = $(d)/local
override_dh_auto_configure:
dh_auto_configure -- --enable-static --enable-shared \
- --libdir=/lib --sbindir=/sbin --disable-audit \
+ --libdir=/lib/$(DEB_HOST_GNU_TYPE) --sbindir=/sbin \
+ --enable-isadir=/lib/security --disable-audit \
CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
# make sure the SAG, MWG, ADG are readable with a browser.
@@ -47,11 +48,17 @@ override_dh_installman:
rm -f $(d)/libpam-modules/usr/share/man/man5/pam.conf.5
rm -f $(d)/libpam-modules/usr/share/man/man8/pam_cracklib.8
+# dh_link doesn't do wildcards, so we can't auto-link to the right per-arch
+# directory
+override_dh_link:
+ sed -e"s,^/lib,/lib/$(DEB_HOST_GNU_TYPE)," $(d)/libpam0g-dev.links.in > $(d)/libpam0g-dev.links
+ dh_link
+
# using perms that differ from upstream (sgid instead of suid) /and/ that
# dh_fixperms doesn't want
override_dh_fixperms:
dh_fixperms
ifneq (,$(findstring libpam-modules, $(shell dh_listpackages)))
- chgrp shadow $(d)/libpam-modules/sbin/unix_chkpwd
- chmod 02755 $(d)/libpam-modules/sbin/unix_chkpwd
+ chgrp shadow $(d)/libpam-modules-bin/sbin/unix_chkpwd
+ chmod 02755 $(d)/libpam-modules-bin/sbin/unix_chkpwd
endif