summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 389e2fb9..6a4b1268 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,7 @@
# architecture-dependant package, as well as an architecture-independant
# package.
+LDFLAGS := -Wl,-z,defs
CFLAGS := -g -D_GNU_SOURCE -D_REENTRANT -fPIC
ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))
@@ -38,7 +39,7 @@ build-stamp:
dh_testdir
# Compile everything else
- $(MAKE) -C $(BUILD_TREE) CFLAGS="$(CFLAGS)"
+ $(MAKE) -C $(BUILD_TREE) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
pod2man --section 8 --release="Debian GNU/Linux" $(dl)/pam_getenv >$(dl)/pam_getenv.8