summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/compat2
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules14
4 files changed, 9 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index b96bbc22..c51d6c32 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,9 @@ pam (1.1.3-3) UNRELEASED; urgency=low
use some awkward language that's gone unnoticed for a long time. Thanks
to Martin Eberhard Schauer <Martin.E.Schauer@gmx.de> for pointing this
out. Closes: #633863.
+ * Build-depend on debhelper 8.9.4 and bump debian/compat to 9 for
+ dpkg-buildflags integration, and drop manual setting of -g -O options in
+ CFLAGS now that we can let dh do it for us
-- Steve Langasek <vorlon@debian.org> Fri, 01 Jul 2011 01:42:19 -0700
diff --git a/debian/compat b/debian/compat
index 7f8f011e..ec635144 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/debian/control b/debian/control
index 4966b510..99835256 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
Uploaders: Sam Hartman <hartmans@debian.org>, Roger Leigh <rleigh@debian.org>
Maintainer: Steve Langasek <vorlon@debian.org>
Standards-Version: 3.9.1
-Build-Depends: libcrack2-dev (>= 2.8), bzip2, debhelper (>= 8.1.3), quilt (>= 0.48-1), flex, libdb-dev, libselinux1-dev [!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64 !netbsd-i386], po-debconf
+Build-Depends: libcrack2-dev (>= 2.8), bzip2, debhelper (>= 8.9.4), quilt (>= 0.48-1), flex, libdb-dev, libselinux1-dev [!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64 !netbsd-i386], po-debconf
Build-Depends-Indep: xsltproc, libxml2-utils, docbook-xml, docbook-xsl, w3m
Build-Conflicts-Indep: fop
Build-Conflicts: libdb4.2-dev, libxcrypt-dev
diff --git a/debian/rules b/debian/rules
index 2c11444c..5784bd1f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,8 @@
#!/usr/bin/make -f
-LDFLAGS := -Wl,-z,defs
-CFLAGS := -g $(shell getconf LFS_CFLAGS)
-
-ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))
-CFLAGS += -O2
-else
-CFLAGS += -O0
-endif
+DEB_LDFLAGS_MAINT_APPEND := -Wl,-z,defs
+DEB_CFLAGS_MAINT_APPEND := $(shell getconf LFS_CFLAGS)
+export DEB_LDFLAGS_MAINT_APPEND DEB_CFLAGS_MAINT_APPEND
DEB_HOST_MULTIARCH := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -25,8 +20,7 @@ dl = $(d)/local
override_dh_auto_configure:
dh_auto_configure -- --enable-static --enable-shared \
--libdir=/lib/$(DEB_HOST_MULTIARCH) --sbindir=/sbin \
- --enable-isadir=/lib/security --disable-audit \
- CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+ --enable-isadir=/lib/security --disable-audit
# make sure the SAG, MWG, ADG are readable with a browser.
override_dh_compress: