summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--[-rwxr-xr-x]debian/local/pam-auth-update0
-rwxr-xr-xdebian/rules8
3 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f20840a7..32210ce4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+pam (1.1.3-11) UNRELEASED; urgency=low
+
+ [ Wookey ]
+ * Disable libaudit for stage1 bootstrap.
+
+ -- Steve Langasek <vorlon@debian.org> Sun, 20 Oct 2013 19:17:07 -0700
+
pam (1.1.3-10) unstable; urgency=low
* Fix pam-auth-update handling of trailing blank lines in the fields of
diff --git a/debian/local/pam-auth-update b/debian/local/pam-auth-update
index 17d3fc66..17d3fc66 100755..100644
--- a/debian/local/pam-auth-update
+++ b/debian/local/pam-auth-update
diff --git a/debian/rules b/debian/rules
index ac2ffab7..873e5cc0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,10 +17,16 @@ dl = $(d)/local
%:
dh $@ --with quilt,autoreconf
+# avoid libaudit-dev when bootstrapping
+ifneq (,$(filter $(DEB_BUILD_PROFILE),stage1))
+ CONFIGURE_OPTS += --disable-audit
+endif
+
override_dh_auto_configure:
dh_auto_configure -- --enable-static --enable-shared \
--libdir=/lib/$(DEB_HOST_MULTIARCH) \
- --enable-isadir=/lib/security --disable-regenerate-docu
+ --enable-isadir=/lib/security \
+ --disable-regenerate-docu $(CONFIGURE_OPTS)
# make sure the SAG, MWG, ADG are readable with a browser.
override_dh_compress: