summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index fe15fbb0..f51eb987 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -17,6 +17,8 @@ pam (1.1.0-3) UNRELEASED; urgency=low
some of it is obsolete by the change in package VCS.
* Convert debian/rules to debhelper 7 and add versioned build-dependencies
on debhelper and quilt to suit.
+ * Drop CFLAGS that we don't need anymore (-fPIC, -D_REENTRANT,
+ -D_GNU_SOURCE).
-- Steve Langasek <vorlon@debian.org> Tue, 01 Sep 2009 22:23:47 -0700
diff --git a/debian/rules b/debian/rules
index 6f0b3cd6..9999af1b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
LDFLAGS := -Wl,-z,defs
-CFLAGS := -g -D_GNU_SOURCE -D_REENTRANT -fPIC
+CFLAGS := -g
ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))
CFLAGS += -O2