summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/patches-applied/dont_freeze_password_chain117
-rw-r--r--debian/patches-applied/series1
-rw-r--r--debian/po/vi.po37
4 files changed, 153 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 9c384356..d6ed50ca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+pam (1.0.1-6) UNRELEASED; urgency=low
+
+ * Updated debconf translations:
+ - Vietnamese, thanks to Clytie Siddall <clytie@riverland.net.au>
+ * New patch dont_freeze_password_chain, cherry-picked from upstream:
+ don't always follow the same path through the password stack on
+ the PAM_UPDATE_AUTHTOK pass as was used in the PAM_PRELIM_CHECK
+ pass; this Linux-PAM deviation from the original PAM spec causes a
+ number of problems, in particular causing wrong return values when
+ using the refactored pam-auth-update stack. LP: #303515, #305882.
+
+ -- Steve Langasek <vorlon@debian.org> Fri, 27 Feb 2009 16:20:24 -0800
+
pam (1.0.1-5) unstable; urgency=low
* Build-conflict with libxcrypt-dev, which otherwise pulls libxcrypt in as
diff --git a/debian/patches-applied/dont_freeze_password_chain b/debian/patches-applied/dont_freeze_password_chain
new file mode 100644
index 00000000..799d0a0e
--- /dev/null
+++ b/debian/patches-applied/dont_freeze_password_chain
@@ -0,0 +1,117 @@
+Don't freeze the chain for chauthtok.
+
+bugzilla.novell.com#470337, LP: #303515.
+
+Author: Thorsten Kukuk <kukuk@thkukuk.de>
+
+Upstream status: cherry-picked from upstream.
+
+=== modified file 'doc/man/pam_sm_chauthtok.3.xml'
+--- doc/man/pam_sm_chauthtok.3.xml 2006-06-28 14:22:40 +0000
++++ doc/man/pam_sm_chauthtok.3.xml 2009-02-18 00:34:47 +0000
+@@ -40,7 +40,7 @@
+ </citerefentry> interface.
+ </para>
+ <para>
+- This function is used to (re-)set the authentication token of the user.
++ This function is used to (re-)set the authentication token of the user.
+ </para>
+ <para>
+ Valid flags, which may be logically OR'd with
+@@ -60,10 +60,10 @@
+ <listitem>
+ <para>
+ This argument indicates to the module that the users
+- authentication token (password) should only be changed if
+- it has expired. This flag is optional and
+- <emphasis>must</emphasis> be combined with one of the
+- following two flags. Note, however, the following two options
++ authentication token (password) should only be changed if
++ it has expired. This flag is optional and
++ <emphasis>must</emphasis> be combined with one of the
++ following two flags. Note, however, the following two options
+ are <emphasis>mutually exclusive</emphasis>.
+ </para>
+ </listitem>
+@@ -72,15 +72,20 @@
+ <term>PAM_PRELIM_CHECK</term>
+ <listitem>
+ <para>
+- This indicates that the modules are being probed as to
+- their ready status for altering the user's authentication
+- token. If the module requires access to another system over
+- some network it should attempt to verify it can connect to
+- this system on receiving this flag. If a module cannot establish
+- it is ready to update the user's authentication token it should
++ This indicates that the modules are being probed as to
++ their ready status for altering the user's authentication
++ token. If the module requires access to another system over
++ some network it should attempt to verify it can connect to
++ this system on receiving this flag. If a module cannot establish
++ it is ready to update the user's authentication token it should
+ return <emphasis remap='B'>PAM_TRY_AGAIN</emphasis>, this
+ information will be passed back to the application.
+ </para>
++ <para>
++ If the control value <emphasis>sufficient</emphasis> is used in
++ the password stack, the <emphasis>PAM_PRELIM_CHECK</emphasis> section
++ of the modules following that control value is not always executed.
++ </para>
+ </listitem>
+ </varlistentry>
+ <varlistentry>
+@@ -89,18 +94,18 @@
+ <para>
+ This informs the module that this is the call it should change
+ the authorization tokens. If the flag is logically OR'd with
+- <emphasis remap='B'>PAM_CHANGE_EXPIRED_AUTHTOK</emphasis>, the
++ <emphasis remap='B'>PAM_CHANGE_EXPIRED_AUTHTOK</emphasis>, the
+ token is only changed if it has actually expired.
+ </para>
+ </listitem>
+ </varlistentry>
+ </variablelist>
+ <para>
+- The PAM library calls this function twice in succession. The first
+- time with <emphasis remap='B'>PAM_PRELIM_CHECK</emphasis> and then,
+- if the module does not return
++ The PAM library calls this function twice in succession. The first
++ time with <emphasis remap='B'>PAM_PRELIM_CHECK</emphasis> and then,
++ if the module does not return
+ <emphasis remap='B'>PAM_TRY_AGAIN</emphasis>, subsequently with
+- <emphasis remap='B'>PAM_UPDATE_AUTHTOK</emphasis>. It is only on
++ <emphasis remap='B'>PAM_UPDATE_AUTHTOK</emphasis>. It is only on
+ the second call that the authorization token is (possibly) changed.
+ </para>
+ </refsect1>
+
+=== modified file 'libpam/pam_dispatch.c'
+--- libpam/pam_dispatch.c 2008-12-03 22:16:33 +0000
++++ libpam/pam_dispatch.c 2009-02-18 00:34:47 +0000
+@@ -132,11 +132,10 @@
+ }
+
+ /*
+- * use_cached_chain is how we ensure that the setcred/close_session
+- * and chauthtok(2) modules are called in the same order as they did
+- * when they were invoked as auth/open_session/chauthtok(1). This
+- * feature was added in 0.75 to make the behavior of pam_setcred
+- * sane. It was debugged by release 0.76.
++ * use_cached_chain is how we ensure that the setcred and
++ * close_session modules are called in the same order as they did
++ * when they were invoked as auth/open_session. This feature was
++ * added in 0.75 to make the behavior of pam_setcred sane.
+ */
+ if (use_cached_chain != _PAM_PLEASE_FREEZE) {
+
+@@ -358,9 +357,6 @@
+ break;
+ case PAM_CHAUTHTOK:
+ h = pamh->handlers.conf.chauthtok;
+- if (flags & PAM_UPDATE_AUTHTOK) {
+- use_cached_chain = _PAM_MUST_BE_FROZEN;
+- }
+ break;
+ default:
+ pam_syslog(pamh, LOG_ERR, "undefined fn choice; %d", choice);
+
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index 8035591b..a1e163ed 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -21,3 +21,4 @@ pam_env_ignore_garbage.patch -p2
pam.d-manpage-section
pam_unix-chkpwd-wait
autoconf.patch
+dont_freeze_password_chain -p0
diff --git a/debian/po/vi.po b/debian/po/vi.po
index 7a0006d0..4dddd25b 100644
--- a/debian/po/vi.po
+++ b/debian/po/vi.po
@@ -1,26 +1,26 @@
# Vietnamese translation for PAM.
-# Copyright © 2007 Free Software Foundation, Inc.
-# Clytie Siddall <clytie@riverland.net.au>, 2007
+# Copyright © 2009 Free Software Foundation, Inc.
+# Clytie Siddall <clytie@riverland.net.au>, 2007-2009.
#
msgid ""
msgstr ""
-"Project-Id-Version: pam 0.99.7.1-5\n"
+"Project-Id-Version: pam 1.0.1-5\n"
"Report-Msgid-Bugs-To: pam@packages.debian.org\n"
"POT-Creation-Date: 2008-12-28 01:17-0600\n"
-"PO-Revision-Date: 2007-09-28 23:58+0930\n"
+"PO-Revision-Date: 2009-01-26 23:08+1030\n"
"Last-Translator: Clytie Siddall <clytie@riverland.net.au>\n"
"Language-Team: Vietnamese <vi-VN@googlegroups.com>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0;\n"
-"X-Generator: LocFactoryEditor 1.7b1\n"
+"X-Generator: LocFactoryEditor 1.8\n"
#. Type: string
#. Description
#: ../libpam0g.templates:1001
msgid "Services to restart for PAM library upgrade:"
-msgstr "Dịch vụ cần khởi chạy lại khi nâng cấp thư viện PAM:"
+msgstr "Dịch vụ cần khởi chạy lại để nâng cấp thư viện PAM:"
#. Type: string
#. Description
@@ -31,10 +31,11 @@ msgid ""
"list of init.d scripts for services to be restarted now, and correct it if "
"needed."
msgstr ""
-"Phần lớn dịch vụ sử dụng PAM cũng cần phải được khởi chạy lại để sử dụng các "
-"mô-đun được xây dựng cho phân vùng libpam mới này. Hãy xem lại danh sách "
-"định giới bằng dấu cách theo đây hiển thị các dịch vụ cần khởi chạy lại ngay "
-"bây giờ, và sửa chữa nếu cần thiết."
+"Phần lớn dịch vụ sử dụng PAM thì cũng cần phải được khởi chạy lại để sử dụng "
+"những mô-đun được xây dựng cho phiên bản libpam mới này. Hãy xem lại danh "
+"sách định giới bằng dấu cách theo đây hiển thị những văn lệnh khởi động "
+"(init.d) cho dịch vụ cần khởi chạy lại ngay bây giờ, và sửa chữa nếu cần "
+"thiết."
#. Type: error
#. Description
@@ -52,9 +53,9 @@ msgid ""
"services by hand before further X logins will be possible."
msgstr ""
"Trình quản lý trình bày kdm, wdm, hay xdm cần thiết được khởi chạy lại để sử "
-"dụng phiên bản mới của thư viện libpam, nhưng việc khởi chạy lại dịch vụ này "
-"sẽ cũng chấm dứt phiên chạy X đang hoạt động. Vì vậy bạn cần phải tự khởi "
-"chạy trình quản lý trình bày để có khả năng sử dụng nó lại."
+"dụng phiên bản mới của thư viện libpam, nhưng việc khởi chạy lại sẽ cũng "
+"chấm dứt một số buổi hợp đang nhập X đang chạy. Sau đó thì bạn cần phải tự "
+"khởi chạy lại những dịch vụ này để đăng nhập lại vào X."
#. Type: error
#. Description
@@ -77,7 +78,7 @@ msgid ""
"You will need to start these manually by running '/etc/init.d/<service> "
"start'."
msgstr ""
-"Bạn cần phải tự khởi chạy lại chúng bằng cách chạy lệnh « /etc/init.d/"
+"Bạn cần phải tự khởi chạy lại chúng bằng cách chạy câu lệnh « /etc/init.d/"
"<tên_dịch_vụ> start »."
#. Type: multiselect
@@ -150,7 +151,7 @@ msgstr ""
#. Description
#: ../libpam-modules.templates:1001
msgid "xscreensaver and xlockmore must be restarted before upgrading"
-msgstr ""
+msgstr "xscreensaver và xlockmore phải được khởi chạy lại trước khi nâng cấp"
#. Type: error
#. Description
@@ -163,3 +164,9 @@ msgid ""
"stopped before continuing this upgrade, to avoid locking your users out of "
"their current sessions."
msgstr ""
+"Một hai nhiều tiến trình xscreensaver hay xlockmore được phát hiện trên hệ "
+"thống này. Do thay đổi thư viện không tương thích, việc nâng cấp gói libpam-"
+"modules sẽ để lại trường hợp người dùng không thể xác thực với những chương "
+"trình này. Vì thế bạn nên khởi chạy lại hoặc ngừng chạy những chương trình "
+"này trước khi tiếp tục tiến trình nâng cấp, để tránh chặn người dùng đăng "
+"nhập vào buổi hợp đang chạy."