summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/local/pam-auth-update6
-rw-r--r--debian/patches-applied/no_PATH_MAX_on_hurd22
-rw-r--r--debian/patches-applied/series1
4 files changed, 34 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e467134a..fb3d347c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,14 @@ pam (1.1.1-5) UNRELEASED; urgency=low
warnings.
* Bump Standards-Version to 3.9.1.
* Add lintian overrides for a few more spurious warnings.
+ * debian/patches-applied/no_PATH_MAX_on_hurd: define PATH_MAX for
+ compatibility when it's not already set. Closes: #552043.
+ * debian/local/pam-auth-update: Don't try to pass embedded newlines to
+ debconf; backslash-escape them instead and use CAPB escape.
+ * debian/local/pam-auth-update: sort additional module options before
+ writing them out, so that we don't wind up with a different config file
+ on every invocation. Thanks to Jim Paris <jim@jtan.com> for the patch.
+ Closes: #594123.
-- Steve Langasek <vorlon@debian.org> Sun, 29 Aug 2010 00:56:28 -0700
diff --git a/debian/local/pam-auth-update b/debian/local/pam-auth-update
index 7f14982d..7010cdca 100755
--- a/debian/local/pam-auth-update
+++ b/debian/local/pam-auth-update
@@ -29,7 +29,7 @@ use Debconf::Client::ConfModule ':all';
use IPC::Open2 'open2';
version('2.0');
-my $capb=capb('backup');
+my $capb=capb('backup escape');
my $inputdir = '/usr/share/pam-configs';
my $template = 'libpam-runtime/profiles';
@@ -200,7 +200,7 @@ do {
}
}
if (@conflicts) {
- subst($errtemplate, 'conflicts', join("\n", @conflicts));
+ subst($errtemplate, 'conflicts', join("\\n", @conflicts));
input('high',$errtemplate);
}
set($template, join(', ', @enabled));
@@ -271,7 +271,7 @@ sub merge_one_line
$i--;
}
}
- return $modline . " " . join(' ',@opts,keys(%{$adds})) . "\n";
+ return $modline . " " . join(' ',@opts,sort keys(%{$adds})) . "\n";
}
# return the lines for a given config name, type, and position in the stack
diff --git a/debian/patches-applied/no_PATH_MAX_on_hurd b/debian/patches-applied/no_PATH_MAX_on_hurd
new file mode 100644
index 00000000..ab7d506c
--- /dev/null
+++ b/debian/patches-applied/no_PATH_MAX_on_hurd
@@ -0,0 +1,22 @@
+Description: define PATH_MAX for compatibility when it's not already set
+ Some platforms, such as the Hurd, don't set PATH_MAX. Set a reasonable
+ default value in this case.
+Author: Steve Langasek <vorlon@debian.org>
+Bug-Debian: http://bugs.debian.org/552043
+
+Index: pam.deb/tests/tst-dlopen.c
+===================================================================
+--- pam.deb.orig/tests/tst-dlopen.c
++++ pam.deb/tests/tst-dlopen.c
+@@ -16,6 +16,11 @@
+ #include <limits.h>
+ #include <sys/stat.h>
+
++/* Hurd compatibility */
++#ifndef PATH_MAX
++#define PATH_MAX 4096
++#endif
++
+ /* Simple program to see if dlopen() would succeed. */
+ int main(int argc, char **argv)
+ {
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index 7455447a..e43bd96f 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -22,3 +22,4 @@ autoconf.patch
update-motd
fix-man-crud
sys-types-include.patch
+no_PATH_MAX_on_hurd