summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches-applied/pam_1.0.4_mindays36
-rw-r--r--debian/patches-applied/series1
3 files changed, 42 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5e6eda5a..9652eb3f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,15 @@
pam (1.0.1-10) UNRELEASED; urgency=low
+ [ Steve Langasek ]
* Updated debconf translations:
- Finnish, thanks to Esko Arajärvi <edu@iki.fi> (closes: #520785)
- Russian, thanks to Yuri Kozlov <yuray@komyakino.ru> (closes: #521874)
- German, thanks to Sven Joachim <svenjoac@gmx.de> (closes: #521530)
+ [ Kees Cook ]
+ * Add debian/patches/pam_1.0.4_mindays: backport upstream 1.0.4 fixes
+ for MINDAYS-Field regression (closes: #514437).
+
-- Steve Langasek <vorlon@debian.org> Sun, 22 Mar 2009 20:36:14 -0700
pam (1.0.1-9) unstable; urgency=low
diff --git a/debian/patches-applied/pam_1.0.4_mindays b/debian/patches-applied/pam_1.0.4_mindays
new file mode 100644
index 00000000..0f766e91
--- /dev/null
+++ b/debian/patches-applied/pam_1.0.4_mindays
@@ -0,0 +1,36 @@
+Index: debian-pkg-pam/modules/pam_unix/pam_unix_acct.c
+===================================================================
+--- debian-pkg-pam.orig/modules/pam_unix/pam_unix_acct.c 2009-04-17 11:30:15.000000000 -0700
++++ debian-pkg-pam/modules/pam_unix/pam_unix_acct.c 2009-04-17 11:31:25.000000000 -0700
+@@ -250,6 +250,9 @@
+ _make_remark(pamh, ctrl, PAM_ERROR_MSG,
+ _("Your account has expired; please contact your system administrator"));
+ break;
++ case PAM_AUTHTOK_ERR:
++ retval = PAM_SUCCESS;
++ /* fallthrough */
+ case PAM_SUCCESS:
+ if (daysleft >= 0) {
+ pam_syslog(pamh, LOG_DEBUG,
+Index: debian-pkg-pam/modules/pam_unix/passverify.c
+===================================================================
+--- debian-pkg-pam.orig/modules/pam_unix/passverify.c 2009-04-17 11:30:07.000000000 -0700
++++ debian-pkg-pam/modules/pam_unix/passverify.c 2009-04-17 11:30:59.000000000 -0700
+@@ -301,8 +301,16 @@
+ *daysleft = (int)((spent->sp_lstchg + spent->sp_max) - curdays);
+ D(("warn before expiry"));
+ }
++ if ((curdays - spent->sp_lstchg < spent->sp_min)
++ && (spent->sp_min != -1)) {
++ /*
++ * The last password change was too recent. This error will be ignored
++ * if no password change is attempted.
++ */
++ D(("password change too recent"));
++ return PAM_AUTHTOK_ERR;
++ }
+ return PAM_SUCCESS;
+-
+ }
+
+ /* passwd/salt conversion macros */
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index a1e163ed..652ce5a9 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -22,3 +22,4 @@ pam.d-manpage-section
pam_unix-chkpwd-wait
autoconf.patch
dont_freeze_password_chain -p0
+pam_1.0.4_mindays