summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches-applied/pam_mail-fix-quiet37
-rw-r--r--debian/patches-applied/series1
3 files changed, 41 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d8ea332f..e48b862b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -15,8 +15,10 @@ pam (1.0.1-10) UNRELEASED; urgency=low
* Remove conflicts information for transitions prior to woody release
* Fix lintian overrides for libpam-runtime
* Overrides for lintian finding quilt patches
+ * pam_mail-fix-quiet: patch from Andreas Henriksson
+ applied upstream to fix quiet option of pam_mail, Closes: #439268
- -- Sam Hartman <hartmans@debian.org> Sat, 30 May 2009 17:00:46 -0400
+ -- Sam Hartman <hartmans@debian.org> Sat, 30 May 2009 17:26:14 -0400
pam (1.0.1-9) unstable; urgency=low
diff --git a/debian/patches-applied/pam_mail-fix-quiet b/debian/patches-applied/pam_mail-fix-quiet
new file mode 100644
index 00000000..7673effa
--- /dev/null
+++ b/debian/patches-applied/pam_mail-fix-quiet
@@ -0,0 +1,37 @@
+Make quiet option of pam_mail work. Fixes http://bugs.debian.org/439268
+
+Author: Andreas Henriksson <andreas@fatal.se>
+Upstream status: applied in upstream CVS September 2008
+
+Index: sid/modules/pam_mail/pam_mail.c
+===================================================================
+--- sid.orig/modules/pam_mail/pam_mail.c 2009-05-30 17:02:33.000000000 -0400
++++ sid/modules/pam_mail/pam_mail.c 2009-05-30 17:20:28.000000000 -0400
+@@ -303,8 +303,13 @@
+ {
+ int retval;
+
+- if (!(ctrl & PAM_MAIL_SILENT) ||
+- ((ctrl & PAM_QUIET_MAIL) && type == HAVE_NEW_MAIL))
++ if ((ctrl & PAM_MAIL_SILENT) ||
++ ((ctrl & PAM_QUIET_MAIL) && type != HAVE_NEW_MAIL))
++ {
++ D(("keeping quiet"));
++ retval = PAM_SUCCESS;
++ }
++ else
+ {
+ if (ctrl & PAM_STANDARD_MAIL)
+ switch (type)
+@@ -345,11 +350,6 @@
+ break;
+ }
+ }
+- else
+- {
+- D(("keeping quiet"));
+- retval = PAM_SUCCESS;
+- }
+
+ D(("returning %s", pam_strerror(pamh, retval)));
+ return retval;
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index 652ce5a9..1b3bddae 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -23,3 +23,4 @@ pam_unix-chkpwd-wait
autoconf.patch
dont_freeze_password_chain -p0
pam_1.0.4_mindays
+pam_mail-fix-quiet