summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches-applied/pam_unix_no_helper_for_nis+.patch31
2 files changed, 0 insertions, 35 deletions
diff --git a/debian/changelog b/debian/changelog
index 513efe20..e47407a8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -35,10 +35,6 @@ pam (1.0.1-1) UNRELEASED; urgency=low
* New patch pam_unix_setreuid_juggling.patch: restore the 0.99.9.0
behavior wrt uid changes for NIS+, since I know the old behavior was
right and don't believe anyone has tested the new code.
- * New patch pam_unix_no_helper_for_nis+.patch, which restores the behavior
- of doing in-process NIS+ account checking instead of unconditionally
- passing it off to the unix_chkpwd helper; if it wasn't broke, don't fix
- it.
* New patch pam_unix_fix_sgid_shadow_auth.patch, fixing an upstream
regression which prevents sgid shadow apps from being able to authenticate
any more because the module forces use of the helper and the helper won't
diff --git a/debian/patches-applied/pam_unix_no_helper_for_nis+.patch b/debian/patches-applied/pam_unix_no_helper_for_nis+.patch
deleted file mode 100644
index 1742034c..00000000
--- a/debian/patches-applied/pam_unix_no_helper_for_nis+.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Don't force use of the helper for account verification with NIS+; the
-previous code already works robustly for any non-threaded caller, and
-will fall back to use of the helper anyway.
-
-Authors: Steve Langasek <vorlon@debian.org>
-
-Upstream status: to be discussed
-
-Index: pam.deb/modules/pam_unix/passverify.c
-===================================================================
---- pam.deb.orig/modules/pam_unix/passverify.c
-+++ pam.deb/modules/pam_unix/passverify.c
-@@ -166,7 +166,6 @@
- if (*pwd != NULL) {
- if (strcmp((*pwd)->pw_passwd, "*NP*") == 0)
- { /* NIS+ */
--#ifdef HELPER_COMPILE
- uid_t save_euid, save_uid;
-
- save_euid = geteuid();
-@@ -194,10 +193,6 @@
-
- if (*spwdent == NULL || (*spwdent)->sp_pwdp == NULL)
- return PAM_AUTHINFO_UNAVAIL;
--#else
-- /* we must run helper for NIS+ passwords */
-- return PAM_UNIX_RUN_HELPER;
--#endif
- } else if (is_pwd_shadowed(*pwd)) {
- /*
- * ...and shadow password file entry for this user,