summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/local/pam-auth-update4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b7013d8e..8b31ddd0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -25,6 +25,8 @@ pam (1.1.2-1) UNRELEASED; urgency=low
* Add lintian overrides for a few more spurious warnings.
* debian/patches-applied/no_PATH_MAX_on_hurd: define PATH_MAX for
compatibility when it's not already set. Closes: #552043.
+ * debian/local/pam-auth-update: Don't try to pass embedded newlines to
+ debconf; backslash-escape them instead and use CAPB escape.
-- Steve Langasek <vorlon@debian.org> Thu, 02 Sep 2010 10:23:42 -0700
diff --git a/debian/local/pam-auth-update b/debian/local/pam-auth-update
index 7f14982d..2f9da0b3 100755
--- a/debian/local/pam-auth-update
+++ b/debian/local/pam-auth-update
@@ -29,7 +29,7 @@ use Debconf::Client::ConfModule ':all';
use IPC::Open2 'open2';
version('2.0');
-my $capb=capb('backup');
+my $capb=capb('backup escape');
my $inputdir = '/usr/share/pam-configs';
my $template = 'libpam-runtime/profiles';
@@ -200,7 +200,7 @@ do {
}
}
if (@conflicts) {
- subst($errtemplate, 'conflicts', join("\n", @conflicts));
+ subst($errtemplate, 'conflicts', join("\\n", @conflicts));
input('high',$errtemplate);
}
set($template, join(', ', @enabled));