summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/libpam0g.postinst4
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 06f59cec..89e0080a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ pam (1.3.1-5) UNRELEASED; urgency=medium
* xdm restart check was inverted in the prior upload; turn it the right
way around
+ * Correctly display the notification when a manual DM restart is needed.
-- Steve Langasek <vorlon@debian.org> Thu, 14 Feb 2019 07:04:50 +0000
diff --git a/debian/libpam0g.postinst b/debian/libpam0g.postinst
index 86d7d2de..953078a0 100644
--- a/debian/libpam0g.postinst
+++ b/debian/libpam0g.postinst
@@ -177,7 +177,9 @@ then
echo "Nothing to restart."
fi
- if who | awk '{print $2}' | grep -q ':[0-9]'; then
+ if [ -n "$(who | awk '$2 ~ /console/ && $NF ~ /:[0-9]/ { print $NF }
+ $2 ~ /:[0-9]/ { print $2 }')" ]
+ then
dms=""
for service in wdm xdm; do
case "$services" in