summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f51eb987..beff6798 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -19,6 +19,7 @@ pam (1.1.0-3) UNRELEASED; urgency=low
on debhelper and quilt to suit.
* Drop CFLAGS that we don't need anymore (-fPIC, -D_REENTRANT,
-D_GNU_SOURCE).
+ * Explicitly add -O0 to CFLAGS when noopt is set.
-- Steve Langasek <vorlon@debian.org> Tue, 01 Sep 2009 22:23:47 -0700
diff --git a/debian/rules b/debian/rules
index 9999af1b..c115d852 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,8 @@ CFLAGS := -g
ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))
CFLAGS += -O2
+else
+CFLAGS += -O0
endif
DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)