summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 826198b1..31085a5c 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -15,16 +15,11 @@ install-data-local:
install -m 644 $(srcdir)/index.html $(DESTDIR)$(DOCDIR)/html/
releasedocs: all
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/html
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs
- cp -av $(srcdir)/index.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ $(mkinstalldirs) $(top_builddir)/Linux-PAM-$(VERSION)/doc/specs
cp -av specs/draft-morgan-pam-current.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/specs/
cp -av specs/rfc86.0.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/specs/
make -C sag releasedocs
make -C adg releasedocs
make -C mwg releasedocs