summaryrefslogtreecommitdiff
path: root/doc/sag
diff options
context:
space:
mode:
Diffstat (limited to 'doc/sag')
-rw-r--r--doc/sag/Makefile.am26
1 files changed, 22 insertions, 4 deletions
diff --git a/doc/sag/Makefile.am b/doc/sag/Makefile.am
index f8d7c5f9..2e81709b 100644
--- a/doc/sag/Makefile.am
+++ b/doc/sag/Makefile.am
@@ -6,7 +6,7 @@ CLEANFILES = Linux-PAM_SAG.fo *~
EXTRA_DIST = $(XMLS)
-XMLS = Linux-PAM_SAG.xml $(shell ls pam_*.xml)
+XMLS = Linux-PAM_SAG.xml $(shell ls $(srcdir)/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_SAG.txt Linux-PAM_SAG.pdf html/*.html
@@ -21,7 +21,7 @@ if ENABLE_GENERATE_PDF
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 2 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl $< > Linux-PAM_SAG.fo
- $(FO2PDF) Linux-PAM_SAG.fo $(srcdir)/$@
+ $(FO2PDF) Linux-PAM_SAG.fo $@
else
echo "No fo2pdf processor installed, skip PDF generation"
endif
@@ -32,10 +32,10 @@ Linux-PAM_SAG.txt: $(XMLS)
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 2 --xinclude --nonet \
- http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $(srcdir)/$@
+ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
html/Linux-PAM_SAG.html: $(XMLS)
- @test -d $(srcdir)/html || mkdir -p $(srcdir)/html
+ @test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
--stringparam root.filename Linux-PAM_SAG \
@@ -46,3 +46,21 @@ html/Linux-PAM_SAG.html: $(XMLS)
--stringparam toc.max.depth 2 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
endif
+
+releasedocs: all
+ test -f html/Linux-PAM_SAG.html && \
+ cp -ap html/Linux-PAM_SAG.html html/sag-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ cp -ap $(srcdir)/html/Linux-PAM_SAG.html \
+ $(srcdir)/html/sag-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ test -f Linux-PAM_SAG.txt && \
+ cp -p Linux-PAM_SAG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ cp -p $(srcdir)/Linux-PAM_SAG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ test -f Linux-PAM_SAG.pdf && \
+ cp -p Linux-PAM_SAG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ cp -p $(srcdir)/Linux-PAM_SAG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/