summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.am11
-rw-r--r--doc/adg/Makefile.am13
-rw-r--r--doc/html/.cvsignore4
-rw-r--r--doc/html/index.html21
-rw-r--r--doc/mwg/Makefile.am13
-rw-r--r--doc/sag/Makefile.am13
6 files changed, 24 insertions, 51 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 826198b1..31085a5c 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -15,16 +15,11 @@ install-data-local:
install -m 644 $(srcdir)/index.html $(DESTDIR)$(DOCDIR)/html/
releasedocs: all
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/html
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt
- mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs
- cp -av $(srcdir)/index.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ $(mkinstalldirs) $(top_builddir)/Linux-PAM-$(VERSION)/doc/specs
cp -av specs/draft-morgan-pam-current.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/specs/
cp -av specs/rfc86.0.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/specs/
make -C sag releasedocs
make -C adg releasedocs
make -C mwg releasedocs
diff --git a/doc/adg/Makefile.am b/doc/adg/Makefile.am
index 57faa841..7ba2ab0d 100644
--- a/doc/adg/Makefile.am
+++ b/doc/adg/Makefile.am
@@ -68,19 +68,20 @@ install-data-local:
$(DESTDIR)$(DOCDIR)/pdf/
releasedocs: all
+ $(mkinstalldirs) $(top_builddir)/Linux-PAM-$(VERSION)/doc/adg/html
test -f html/Linux-PAM_ADG.html && \
cp -ap html/Linux-PAM_ADG.html html/adg-*.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/adg/html/ || \
cp -ap $(srcdir)/html/Linux-PAM_ADG.html \
$(srcdir)/html/adg-*.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/adg/html/
test -f Linux-PAM_ADG.txt && \
cp -p Linux-PAM_ADG.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/adg/ || \
cp -p $(srcdir)/Linux-PAM_ADG.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/adg/
test -f Linux-PAM_ADG.pdf && \
cp -p Linux-PAM_ADG.pdf \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/adg/ || \
cp -p $(srcdir)/Linux-PAM_ADG.pdf \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/adg/
diff --git a/doc/html/.cvsignore b/doc/html/.cvsignore
deleted file mode 100644
index 6bd399cb..00000000
--- a/doc/html/.cvsignore
+++ /dev/null
@@ -1,4 +0,0 @@
-pam*.html
-Makefile
-Makefile.in
-
diff --git a/doc/html/index.html b/doc/html/index.html
deleted file mode 100644
index 1ffd7e38..00000000
--- a/doc/html/index.html
+++ /dev/null
@@ -1,21 +0,0 @@
-
-<HTML>
-<HEAD>
-<TITLE>Linux-PAM - Pluggable Authentication Modules for Linux</TITLE>
-</HEAD>
-<BODY>
-
-<p>
-Here is the documentation for Linux-PAM. As you will see it is
-currently not complete. However, in order of decreasing length:
-
-<ul>
-<li> <a href="pam.html">The System Administrators' Guide</a>
-<li> <a href="pam_modules.html">The Module Writers' Manual</a>
-<li> <a href="pam_appl.html">The Application developers' Manual</a>
-</ul>
-
-<hr>
-<p>
-REVISION: <tt>$Id$</tt>
-</BODY>
diff --git a/doc/mwg/Makefile.am b/doc/mwg/Makefile.am
index b9f19764..f1b452f1 100644
--- a/doc/mwg/Makefile.am
+++ b/doc/mwg/Makefile.am
@@ -68,19 +68,20 @@ install-data-local:
$(DESTDIR)$(DOCDIR)/pdf/
releasedocs: all
+ $(mkinstalldirs) $(top_builddir)/Linux-PAM-$(VERSION)/doc/mwg/html
test -f html/Linux-PAM_MWG.html && \
cp -ap html/Linux-PAM_MWG.html html/mwg-*.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/mwg/html/ || \
cp -ap $(srcdir)/html/Linux-PAM_MWG.html \
$(srcdir)/html/mwg-*.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/mwg/html/
test -f Linux-PAM_MWG.txt && \
cp -p Linux-PAM_MWG.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/mwg/ || \
cp -p $(srcdir)/Linux-PAM_MWG.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/mwg/
test -f Linux-PAM_MWG.pdf && \
cp -p Linux-PAM_MWG.pdf \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/mwg/ || \
cp -p $(srcdir)/Linux-PAM_MWG.pdf \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/mwg/
diff --git a/doc/sag/Makefile.am b/doc/sag/Makefile.am
index 71f2d689..1efc6d4e 100644
--- a/doc/sag/Makefile.am
+++ b/doc/sag/Makefile.am
@@ -68,19 +68,20 @@ install-data-local:
$(DESTDIR)$(DOCDIR)/pdf/
releasedocs: all
+ $(mkinstalldirs) $(top_builddir)/Linux-PAM-$(VERSION)/doc/sag/html
test -f html/Linux-PAM_SAG.html && \
cp -ap html/Linux-PAM_SAG.html html/sag-*.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/sag/html/ || \
cp -ap $(srcdir)/html/Linux-PAM_SAG.html \
$(srcdir)/html/sag-*.html \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/sag/html/
test -f Linux-PAM_SAG.txt && \
cp -p Linux-PAM_SAG.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/sag/ || \
cp -p $(srcdir)/Linux-PAM_SAG.txt \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/sag/
test -f Linux-PAM_SAG.pdf && \
cp -p Linux-PAM_SAG.pdf \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/sag/ || \
cp -p $(srcdir)/Linux-PAM_SAG.pdf \
- $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/
+ $(top_builddir)/Linux-PAM-$(VERSION)/doc/sag/