summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.am (renamed from doc/Makefile)120
1 files changed, 48 insertions, 72 deletions
diff --git a/doc/Makefile b/doc/Makefile.am
index b7475694..b1be7c36 100644
--- a/doc/Makefile
+++ b/doc/Makefile.am
@@ -1,9 +1,6 @@
-
-### $Id$
-
-include ../Make.Rules
-
-#######################################################
+#
+# Copyright (c) 2005 Thorsten Kukuk <kukuk@suse.de>
+#
FILES=pam pam_appl pam_modules
FSRCS=pam.sgml pam_appl.sgml pam_modules.sgml
@@ -11,26 +8,33 @@ FSRCS=pam.sgml pam_appl.sgml pam_modules.sgml
TEXTS=txts/pam.txt txts/pam_appl.txt txts/pam_modules.txt
HTMLS=html/pam.html html/pam_appl.html html/pam_modules.html
PSFILES=ps/pam.ps ps/pam_appl.ps ps/pam_modules.ps
-PDFFILES=pdf/pam.pdf ps/pam_appl.pdf ps/pam_modules.pdf
+PDFFILES=pdf/pam.pdf pdf/pam_appl.pdf pdf/pam_modules.pdf
MODULES=$(shell ls modules/*.sgml)
-#######################################################
+CLEANFILES = *~ */*~ $(TEXTS) $(PSFILES) $(PDFFILES) html/*.html \
+ ps/missfont.log MODULES-SGML pam.sgml \
+ specs/draft-morgan-pam-current.txt
-dummy:
- @echo "Making the documentation..."
- @$(MAKE) all
+EXTRA_DIST = $(FSRCS) CREDITS NOTES figs/pam_orient.txt pdf/README \
+ ps/README html/README txts/README man/template-man $(MANS) \
+ pam_source.sgml $(MODULES) modules/module.sgml-template \
+ modules/README
-# note, at this time we don't include pdf files by default, but you
-# can type make pdf in this directory and see what happens in the pdf
-# subdirectory.
+man_MANS = $(addprefix man/, pam.8 pam.conf.8 pam.d.8 pam_authenticate.3 \
+ pam_chauthtok.3 pam_close_session.3 pam_end.3 pam_fail_delay.3 \
+ pam_get_item.3 pam_open_session.3 pam_set_item.3 pam_setcred.3 \
+ pam_start.3 pam_strerror.3)
-all: htmls texts postscript pdf
+#######################################################
+
+all: html text postscript pdf
-htmls: $(HTMLS)
+html: $(HTMLS)
$(HTMLS) : $(FSRCS)
-ifeq ($(HAVE_SGML2HTML),yes)
+ @echo 'Building html documentation from files in modules/*.sgml'
+if HAVE_SGML2HTML
@for i in $(FILES) ; do \
if [ ! -f "html/$$i.html" ] || [ "$$i.sgml" -nt "html/$$i.html" ]; \
then \
@@ -43,10 +47,11 @@ else
@echo XXX - you do not have the sgml2html binary installed
endif
-texts: $(TEXTS)
+text: $(TEXTS)
$(TEXTS) : $(FSRCS)
-ifeq ($(HAVE_SGML2TXT),yes)
+ @echo 'Building text documentation from files in modules/*.sgml'
+if HAVE_SGML2TXT
@for i in $(FILES) ; do \
if [ ! -f "txts/$$i.txt" ] \
|| [ "$$i.sgml" -nt "txts/$$i.txt" ]; then \
@@ -60,7 +65,8 @@ endif
postscript: $(PSFILES)
$(PSFILES): $(FSRCS)
-ifneq ($(PSER),)
+ @echo 'Building postscript documentation from files in modules/*.sgml'
+if HAVE_SGML2PS
@for i in $(FILES) ; do \
if [ ! -f "ps/$$i.ps" ] || [ "$$i.sgml" -nt "ps/$$i.ps" ]; then \
cd ps ; $(PSER) ../$$i ; cd .. ; \
@@ -73,7 +79,9 @@ endif
pdf: $(PDFFILES)
$(PDFFILES) : $(PSFILES)
-ifeq ($(HAVE_PS2PDF),yes)
+ @echo 'Building PDF documentation from files in modules/*.sgml'
+if HAVE_SGML2PS
+if HAVE_PS2PDF
@for i in $(FILES) ; do \
if [ ! -f "pdf/$$i.pdf" ] || [ "ps/$$i.ps" -nt "ps/$$i.pdf" ]; then \
ps2pdf ps/$$i.ps pdf/$$i.pdf ; \
@@ -82,6 +90,9 @@ ifeq ($(HAVE_PS2PDF),yes)
else
@echo XXX - ps2pdf is not installed
endif
+else
+ @echo XXX - neither sgml2ps nor sgml2latex binaries are installed
+endif
pam.sgml: pam_source.sgml MODULES-SGML CREDITS
@sed -e '/^<!\-\- insert\-file MODULES\-SGML \-\->/r MODULES-SGML' pam_source.sgml | sed -e '/^<!\-\- insert\-file CREDITS \-\->/r CREDITS' > pam.sgml
@@ -96,74 +107,39 @@ MODULES-SGML: $(MODULES)
extraclean: clean
-remove:
- cd man && for file in *.3 ; do \
- rm -f $(FAKEROOT)$(MANDIR)/man3/$$file ; \
- done
- cd man && for file in *.8 ; do \
- rm -f $(FAKEROOT)$(MANDIR)/man8/$$file ; \
- done
- cd txts && for file in *.txt; do \
- rm -f $(FAKEROOT)$(DOCDIR)/text/$$file ; \
- done
- cd ps && for file in *.ps; do \
- rm -f $(FAKEROOT)$(DOCDIR)/ps/$$file ; \
- done
- cd html && for file in *.html; do \
- rm -f $(FAKEROOT)$(DOCDIR)/html/$$file ; \
- done
-
-install: all
-ifeq ($(HAVE_SGML2TXT),yes)
- mkdir -p $(FAKEROOT)$(DOCDIR)/text
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(DOCDIR)
+if HAVE_SGML2TXT
+ $(mkinstalldirs) $(DESTDIR)$(DOCDIR)/text
for file in txts/*.txt; do \
- install -m 644 $$file $(FAKEROOT)$(DOCDIR)/text ; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(DOCDIR)/text
done
endif
-ifneq ($(PSER),)
- mkdir -p $(FAKEROOT)$(DOCDIR)/ps
+if HAVE_SGML2PS
+ $(mkinstalldirs) $(DESTDIR)$(DOCDIR)/ps
for file in ps/*.ps; do \
- install -m 644 $$file $(FAKEROOT)$(DOCDIR)/ps ; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(DOCDIR)/ps
done
-ifeq ($(HAVE_PS2PDF),yes)
- mkdir -p $(FAKEROOT)$(DOCDIR)/pdf
+if HAVE_PS2PDF
+ $(mkinstalldirs) $(DESTDIR)$(DOCDIR)/pdf
for file in pdf/*.pdf; do \
- install -m 644 $$file $(FAKEROOT)$(DOCDIR)/pdf ; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(DOCDIR)/pdf
done
endif
endif
-ifeq ($(HAVE_SGML2HTML),yes)
- mkdir -p $(FAKEROOT)$(DOCDIR)/html
+if HAVE_SGML2HTML
+ $(mkinstalldirs) $(DESTDIR)$(DOCDIR)/html
for file in html/*.html; do \
- install -m 644 $$file $(FAKEROOT)$(DOCDIR)/html ; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(DOCDIR)/html
done
endif
- mkdir -p $(FAKEROOT)$(MANDIR)/man3
- mkdir -p $(FAKEROOT)$(MANDIR)/man8
- for file in man/*.3 ; do \
- install -m 644 $$file $(FAKEROOT)$(MANDIR)/man3 ; \
- done
- for file in man/*.8 ; do \
- install -m 644 $$file $(FAKEROOT)$(MANDIR)/man8 ; \
- done
spec: specs/draft-morgan-pam.raw
cd specs/formatter && $(MAKE)
specs/formatter/padout < specs/draft-morgan-pam.raw > specs/draft-morgan-pam-current.txt
releasedocs: all spec
- tar zvfc Linux-PAM-$(MAJOR_REL).$(MINOR_REL)-docs.tar.gz \
+ tar zvfc Linux-PAM-$(VERSION)-docs.tar.gz \
--exclude CVS --exclude .cvsignore --exclude '.#*' \
- html ps txts specs/draft-morgan-pam-current.txt
-
-clean:
- rm -f *~ *.bak
- rm -f html/pam*.html
- rm -f man/*~
- rm -f $(TEXTS)
- rm -f $(PSFILES) ps/missfont.log
- rm -f pdf/*.pdf
- rm -f MODULES-SGML pam.sgml
- rm -f specs/draft-morgan-pam-current.txt
- $(MAKE) -C specs/formatter clean
+ html ps txts pdf specs/draft-morgan-pam-current.txt