summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
Diffstat (limited to 'doc')
-rw-r--r--doc/adg/Makefile.am7
-rw-r--r--doc/mwg/Makefile.am7
-rw-r--r--doc/sag/Linux-PAM_SAG.xml4
-rw-r--r--doc/sag/Makefile.am8
-rw-r--r--doc/sag/pam_unix.xml34
5 files changed, 50 insertions, 10 deletions
diff --git a/doc/adg/Makefile.am b/doc/adg/Makefile.am
index d2531db2..5686e240 100644
--- a/doc/adg/Makefile.am
+++ b/doc/adg/Makefile.am
@@ -7,13 +7,14 @@ CLEANFILES = Linux-PAM_ADG.fo *~
EXTRA_DIST = $(XMLS)
XMLS = Linux-PAM_ADG.xml $(shell ls $(srcdir)/pam_*.xml)
+DEP_XMLS = $(shell ls $(top_srcdir)/doc/man/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_ADG.txt Linux-PAM_ADG.pdf html/*.html
all: Linux-PAM_ADG.txt html/Linux-PAM_ADG.html Linux-PAM_ADG.pdf
-Linux-PAM_ADG.pdf: $(XMLS)
+Linux-PAM_ADG.pdf: $(XMLS) $(DEP_XMLS)
if ENABLE_GENERATE_PDF
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
@@ -26,7 +27,7 @@ else
echo "No fo2pdf processor installed, skip PDF generation"
endif
-Linux-PAM_ADG.txt: $(XMLS)
+Linux-PAM_ADG.txt: $(XMLS) $(DEP_XMLS)
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
--stringparam section.autolabel 1 \
@@ -34,7 +35,7 @@ Linux-PAM_ADG.txt: $(XMLS)
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
-html/Linux-PAM_ADG.html: $(XMLS)
+html/Linux-PAM_ADG.html: $(XMLS) $(DEP_XMLS)
@test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
diff --git a/doc/mwg/Makefile.am b/doc/mwg/Makefile.am
index dbda086f..3d911247 100644
--- a/doc/mwg/Makefile.am
+++ b/doc/mwg/Makefile.am
@@ -7,13 +7,14 @@ CLEANFILES = Linux-PAM_MWG.fo *~
EXTRA_DIST = $(XMLS)
XMLS = Linux-PAM_MWG.xml $(shell ls $(srcdir)/pam_*.xml)
+DEP_XMLS = $(shell ls $(top_srcdir)/doc/man/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_MWG.txt Linux-PAM_MWG.pdf html/*.html
all: Linux-PAM_MWG.txt html/Linux-PAM_MWG.html Linux-PAM_MWG.pdf
-Linux-PAM_MWG.pdf: $(XMLS)
+Linux-PAM_MWG.pdf: $(XMLS) $(DEP_XMLS)
if ENABLE_GENERATE_PDF
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
@@ -26,7 +27,7 @@ else
echo "No fo2pdf processor installed, skip PDF generation"
endif
-Linux-PAM_MWG.txt: $(XMLS)
+Linux-PAM_MWG.txt: $(XMLS) $(DEP_XMLS)
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
--stringparam section.autolabel 1 \
@@ -34,7 +35,7 @@ Linux-PAM_MWG.txt: $(XMLS)
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
-html/Linux-PAM_MWG.html: $(XMLS)
+html/Linux-PAM_MWG.html: $(XMLS) $(DEP_XMLS)
@test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
diff --git a/doc/sag/Linux-PAM_SAG.xml b/doc/sag/Linux-PAM_SAG.xml
index 605516c0..6ba69fa6 100644
--- a/doc/sag/Linux-PAM_SAG.xml
+++ b/doc/sag/Linux-PAM_SAG.xml
@@ -16,7 +16,7 @@
<email>kukuk@thkukuk.de</email>
</author>
</authorgroup>
- <releaseinfo>Version 0.99.6.0, 5. August 2006</releaseinfo>
+ <releaseinfo>Version 0.99.6.4, 20. September 2006</releaseinfo>
<abstract>
<para>
This manual documents what a system-administrator needs to know about
@@ -459,6 +459,8 @@ session required pam_warn.so
<xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
href="pam_umask.xml"/>
<xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="pam_unix.xml"/>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
href="pam_userdb.xml"/>
<xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
href="pam_warn.xml"/>
diff --git a/doc/sag/Makefile.am b/doc/sag/Makefile.am
index fe1e7835..ea8476ee 100644
--- a/doc/sag/Makefile.am
+++ b/doc/sag/Makefile.am
@@ -8,12 +8,14 @@ EXTRA_DIST = $(XMLS)
XMLS = Linux-PAM_SAG.xml $(shell ls $(srcdir)/pam_*.xml)
+DEP_XMLS = $(shell ls $(top_srcdir)/modules/pam_*/pam_*.xml)
+
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_SAG.txt Linux-PAM_SAG.pdf html/*.html
all: Linux-PAM_SAG.txt html/Linux-PAM_SAG.html Linux-PAM_SAG.pdf
-Linux-PAM_SAG.pdf: $(XMLS)
+Linux-PAM_SAG.pdf: $(XMLS) $(DEP_XMLS)
if ENABLE_GENERATE_PDF
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
@@ -26,7 +28,7 @@ else
echo "No fo2pdf processor installed, skip PDF generation"
endif
-Linux-PAM_SAG.txt: $(XMLS)
+Linux-PAM_SAG.txt: $(XMLS) $(DEP_XMLS)
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam generate.toc "book toc" \
--stringparam section.autolabel 1 \
@@ -34,7 +36,7 @@ Linux-PAM_SAG.txt: $(XMLS)
--stringparam toc.max.depth 2 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
-html/Linux-PAM_SAG.html: $(XMLS)
+html/Linux-PAM_SAG.html: $(XMLS) $(DEP_XMLS)
@test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
diff --git a/doc/sag/pam_unix.xml b/doc/sag/pam_unix.xml
new file mode 100644
index 00000000..57b2f9d2
--- /dev/null
+++ b/doc/sag/pam_unix.xml
@@ -0,0 +1,34 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE section PUBLIC "-//OASIS//DTD DocBook XML V4.4//EN"
+ "http://www.oasis-open.org/docbook/xml/4.4/docbookx.dtd">
+<section id='sag-pam_unix'>
+ <title>pam_unix - traditional password authentication</title>
+ <cmdsynopsis>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="../../modules/pam_unix/pam_unix.8.xml" xpointer='xpointer(//cmdsynopsis[@id = "pam_unix-cmdsynopsis"]/*)'/>
+ </cmdsynopsis>
+ <section id='sag-pam_unix-description'>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="../../modules/pam_unix/pam_unix.8.xml" xpointer='xpointer(//refsect1[@id = "pam_unix-description"]/*)'/>
+ </section>
+ <section id='sag-pam_unix-options'>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="../../modules/pam_unix/pam_unix.8.xml" xpointer='xpointer(//refsect1[@id = "pam_unix-options"]/*)'/>
+ </section>
+ <section id='sag-pam_unix-services'>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="../../modules/pam_unix/pam_unix.8.xml" xpointer='xpointer(//refsect1[@id = "pam_unix-services"]/*)'/>
+ </section>
+ <section id='sag-pam_unix-return_values'>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="../../modules/pam_unix/pam_unix.8.xml" xpointer='xpointer(//refsect1[@id = "pam_unix-return_values"]/*)'/>
+ </section>
+ <section id='sag-pam_unix-examples'>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="../../modules/pam_unix/pam_unix.8.xml" xpointer='xpointer(//refsect1[@id = "pam_unix-examples"]/*)'/>
+ </section>
+ <section id='sag-pam_unix-author'>
+ <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+ href="../../modules/pam_unix/pam_unix.8.xml" xpointer='xpointer(//refsect1[@id = "pam_unix-author"]/*)'/>
+ </section>
+</section>