summaryrefslogtreecommitdiff
path: root/libpam/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libpam/Makefile')
-rw-r--r--libpam/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/libpam/Makefile b/libpam/Makefile
index b734dfa4..64fe13a4 100644
--- a/libpam/Makefile
+++ b/libpam/Makefile
@@ -22,7 +22,9 @@ dummy: ../Make.Rules all
# ---------------------------------------------
-CFLAGS += $(DYNAMIC) $(STATIC) $(MOREFLAGS)
+CFLAGS += $(DYNAMIC) $(STATIC) $(MOREFLAGS) \
+ -DLIBPAM_VERSION_MAJOR=$(MAJOR_REL) \
+ -DLIBPAM_VERSION_MINOR=$(MINOR_REL)
# dynamic library names
@@ -95,9 +97,9 @@ ifeq ($(DYNAMIC_LIBPAM),yes)
endif
ifeq ($(NEEDSONAME),yes)
rm -f $(LIBPAMFULL)
- ln -s $(LIBPAM) $(LIBPAMFULL)
+ ln -sf $(LIBPAM) $(LIBPAMFULL)
rm -f $(LIBPAMNAME)
- ln -s $(LIBPAM) $(LIBPAMNAME)
+ ln -sf $(LIBPAM) $(LIBPAMNAME)
endif
endif
@@ -122,7 +124,7 @@ ifeq ($(DYNAMIC_LIBPAM),yes)
$(LDCONFIG)
ifneq ($(DYNTYPE),"sl")
( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBPAM) ; \
- ln -s $(LIBPAMNAME) $(LIBPAM) )
+ ln -sf $(LIBPAMNAME) $(LIBPAM) )
endif
endif
ifeq ($(STATIC_LIBPAM),yes)