summaryrefslogtreecommitdiff
path: root/libpam/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'libpam/Makefile')
-rw-r--r--libpam/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/libpam/Makefile b/libpam/Makefile
index e2b9649e..6728d635 100644
--- a/libpam/Makefile
+++ b/libpam/Makefile
@@ -128,7 +128,11 @@ ifdef MEMORY_DEBUG
endif
ifeq ($(DYNAMIC_LIBPAM),yes)
$(INSTALL) -m $(SHLIBMODE) $(LIBPAM) $(FAKEROOT)$(libdir)/$(LIBPAMFULL)
+ifndef FAKEROOT
$(LDCONFIG)
+else
+ $(LDCONFIG) -n $(FAKEROOT)$(libdir)
+endif
ifneq ($(DYNTYPE),"sl")
( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBPAM) ; \
ln -sf $(LIBPAMNAME) $(LIBPAM) )
@@ -146,7 +150,9 @@ remove:
rm -f $(FAKEROOT)$(INCLUDED)/pam_malloc.h
rm -f $(FAKEROOT)$(libdir)/$(LIBPAM).*
rm -f $(FAKEROOT)$(libdir)/$(LIBPAM)
+ifndef FAKEROOT
$(LDCONFIG)
+endif
rm -f $(FAKEROOT)$(libdir)/$(LIBPAMSTATIC)
clean: