summaryrefslogtreecommitdiff
path: root/libpam
diff options
context:
space:
mode:
Diffstat (limited to 'libpam')
-rw-r--r--libpam/Makefile.am2
-rw-r--r--libpam/include/security/_pam_types.h7
2 files changed, 4 insertions, 5 deletions
diff --git a/libpam/Makefile.am b/libpam/Makefile.am
index f609f8a7..41a71869 100644
--- a/libpam/Makefile.am
+++ b/libpam/Makefile.am
@@ -16,7 +16,7 @@ include_HEADERS = $(addprefix include/security/, _pam_compat.h _pam_macros.h _pa
noinst_HEADERS = pam_dynamic.h pam_prelude.h pam_private.h pam_tokens.h \
pam_modutil_private.h
-libpam_la_LDFLAGS = -no-undefined -version-info 81:1:81
+libpam_la_LDFLAGS = -no-undefined -version-info 81:2:81
if HAVE_VERSIONING
libpam_la_LDFLAGS += -Wl,--version-script=$(srcdir)/libpam.map
endif
diff --git a/libpam/include/security/_pam_types.h b/libpam/include/security/_pam_types.h
index 6815b459..a55dba9c 100644
--- a/libpam/include/security/_pam_types.h
+++ b/libpam/include/security/_pam_types.h
@@ -171,7 +171,7 @@ typedef struct pam_handle pam_handle_t;
extern int PAM_NONNULL((1))
pam_set_item(pam_handle_t *pamh, int item_type, const void *item);
-extern int PAM_NONNULL((1,3))
+extern int PAM_NONNULL((1))
pam_get_item(const pam_handle_t *pamh, int item_type, const void **item);
extern const char *
@@ -309,13 +309,13 @@ struct pam_conv {
* 3. The name of the author may not be used to endorse or promote
* products derived from this software without specific prior
* written permission.
- *
+ *
* ALTERNATIVELY, this product may be distributed under the terms of
* the GNU Public License, in which case the provisions of the GPL are
* required INSTEAD OF the above restrictions. (This clause is
* necessary due to a potential bad interaction between the GPL and
* the restrictions contained in a BSD-style copyright.)
- *
+ *
* THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED
* WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
* OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
@@ -329,4 +329,3 @@ struct pam_conv {
* OF THE POSSIBILITY OF SUCH DAMAGE. */
#endif /* _SECURITY__PAM_TYPES_H */
-