summaryrefslogtreecommitdiff
path: root/modules/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 5596fff3..fc75fe64 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -2,6 +2,10 @@
# Copyright (c) 2005, 2006, 2008 Thorsten Kukuk <kukuk@thkukuk.de>
#
+if COND_BUILD_PAM_CRACKLIB
+ MAYBE_PAM_CRACKLIB = pam_cracklib
+endif
+
if COND_BUILD_PAM_KEYINIT
MAYBE_PAM_KEYINIT = pam_keyinit
endif
@@ -24,7 +28,7 @@ endif
SUBDIRS := \
pam_access \
- pam_cracklib \
+ $(MAYBE_PAM_CRACKLIB) \
pam_debug \
pam_deny \
pam_echo \