summaryrefslogtreecommitdiff
path: root/modules/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'modules/Makefile')
-rw-r--r--modules/Makefile20
1 files changed, 3 insertions, 17 deletions
diff --git a/modules/Makefile b/modules/Makefile
index 9b89ccfd..51964e5b 100644
--- a/modules/Makefile
+++ b/modules/Makefile
@@ -6,19 +6,12 @@
#
#
-MODDIRS=$(shell /bin/ls -d pam_*)
-
-# ////////////////////////////////////////////////////
-# // You should not modify anything below this line //
-# ////////////////////////////////////////////////////
+include ../Make.Rules
-dummy:
- @echo "*** This is not a top-level Makefile! ***"
-
-# -----------------------------------------------------------
+MODDIRS=$(shell /bin/ls -d pam_*)
all:
- @echo modules for $(OS) are:
+ @echo modules sources available are:
@ls -d $(MODDIRS) 2>/dev/null ; echo :--------
@echo
ifdef STATIC
@@ -61,10 +54,3 @@ clean: lclean
} fi ; \
done
-extraclean: lclean
- for i in $(MODDIRS) ; do \
- if [ -d $$i ]; then \
- $(MAKE) -C $$i extraclean ; \
- fi ; \
- done
-