summaryrefslogtreecommitdiff
path: root/modules/pam_debug
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_debug')
-rw-r--r--modules/pam_debug/Makefile15
-rw-r--r--modules/pam_debug/Makefile.am18
2 files changed, 18 insertions, 15 deletions
diff --git a/modules/pam_debug/Makefile b/modules/pam_debug/Makefile
deleted file mode 100644
index ae22cade..00000000
--- a/modules/pam_debug/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# $Id$
-#
-# This Makefile controls a build process of $(TITLE) module for
-# Linux-PAM. You should not modify this Makefile (unless you know
-# what you are doing!).
-#
-# Created by Andrew Morgan <morgan@linux.kernel.org> 2000/08/27
-#
-
-include ../../Make.Rules
-
-TITLE=pam_debug
-
-include ../Simple.Rules
diff --git a/modules/pam_debug/Makefile.am b/modules/pam_debug/Makefile.am
new file mode 100644
index 00000000..79d5f028
--- /dev/null
+++ b/modules/pam_debug/Makefile.am
@@ -0,0 +1,18 @@
+#
+# Copyright (c) 2005 Thorsten Kukuk <kukuk@suse.de>
+#
+
+CLEANFILES = *~
+
+EXTRA_DIST = README
+
+securelibdir = $(SECUREDIR)
+secureconfdir = $(SCONFIGDIR)
+
+AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
+ -I$(top_srcdir)/modules/pammodutil/include/
+AM_LDFLAGS = -avoid-version -module \
+ -L$(top_builddir)/modules/pammodutil -lpammodutil \
+ -L$(top_builddir)/libpam -lpam
+
+securelib_LTLIBRARIES = pam_debug.la