summaryrefslogtreecommitdiff
path: root/modules/pam_deny/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_deny/Makefile.am')
-rw-r--r--modules/pam_deny/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/modules/pam_deny/Makefile.am b/modules/pam_deny/Makefile.am
index 4fe567a6..aa484074 100644
--- a/modules/pam_deny/Makefile.am
+++ b/modules/pam_deny/Makefile.am
@@ -4,7 +4,10 @@
CLEANFILES = *~
-EXTRA_DIST = README
+EXTRA_DIST = README README.xml $(MANS) $(XMLS)
+
+man_MANS = pam_deny.8
+man_XMLS = pam_deny.8.xml
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
@@ -17,3 +20,13 @@ if HAVE_VERSIONING
endif
securelib_LTLIBRARIES = pam_deny.la
+
+if ENABLE_REGENERATE_MAN
+
+noinst_DATA = README
+
+README: pam_deny.8.xml
+
+-include $(top_srcdir)/Make.xml.rules
+endif
+