summaryrefslogtreecommitdiff
path: root/modules/pam_group
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_group')
-rw-r--r--modules/pam_group/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/modules/pam_group/Makefile.am b/modules/pam_group/Makefile.am
index 7846d6b1..85d0e5ad 100644
--- a/modules/pam_group/Makefile.am
+++ b/modules/pam_group/Makefile.am
@@ -12,9 +12,12 @@ secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
-I$(top_srcdir)/modules/pammodutil/include/ \
-DPAM_GROUP_CONF=\"$(SCONFIGDIR)/group.conf\"
-AM_LDFLAGS = -avoid-version -module \
+AM_LDFLAGS = -no-undefined -avoid-version -module \
-L$(top_builddir)/modules/pammodutil -lpammodutil \
-L$(top_builddir)/libpam -lpam
+if HAVE_VERSIONING
+ AM_LDFLAGS += -Wl,--version-script=../modules.map
+endif
securelib_LTLIBRARIES = pam_group.la