summaryrefslogtreecommitdiff
path: root/modules/pam_lastlog/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_lastlog/Makefile.am')
-rw-r--r--modules/pam_lastlog/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/modules/pam_lastlog/Makefile.am b/modules/pam_lastlog/Makefile.am
index 73ee4be6..e81e7833 100644
--- a/modules/pam_lastlog/Makefile.am
+++ b/modules/pam_lastlog/Makefile.am
@@ -7,7 +7,10 @@ CLEANFILES = *~
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
-EXTRA_DIST = README tst-pam_lastlog
+EXTRA_DIST = README $(MANS) $(XMLS) tst-pam_lastlog
+
+man_MANS = pam_lastlog.8
+XMLS = README.xml pam_lastlog.8.xml
TESTS = tst-pam_lastlog
@@ -19,3 +22,10 @@ if HAVE_VERSIONING
endif
securelib_LTLIBRARIES = pam_lastlog.la
+
+if ENABLE_REGENERATE_MAN
+noinst_DATA = README
+README: pam_lastlog.8.xml
+-include $(top_srcdir)/Make.xml.rules
+endif
+