summaryrefslogtreecommitdiff
path: root/modules/pam_nologin
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_nologin')
-rw-r--r--modules/pam_nologin/Makefile15
-rw-r--r--modules/pam_nologin/Makefile.am20
-rw-r--r--modules/pam_nologin/pam_nologin.886
3 files changed, 106 insertions, 15 deletions
diff --git a/modules/pam_nologin/Makefile b/modules/pam_nologin/Makefile
deleted file mode 100644
index 130787e7..00000000
--- a/modules/pam_nologin/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# $Id$
-#
-# This Makefile controls a build process of $(TITLE) module for
-# Linux-PAM. You should not modify this Makefile (unless you know
-# what you are doing!).
-#
-# Created by Andrew Morgan <morgan@linux.kernel.org> 2000/08/27
-#
-
-include ../../Make.Rules
-
-TITLE=pam_nologin
-
-include ../Simple.Rules
diff --git a/modules/pam_nologin/Makefile.am b/modules/pam_nologin/Makefile.am
new file mode 100644
index 00000000..a2549346
--- /dev/null
+++ b/modules/pam_nologin/Makefile.am
@@ -0,0 +1,20 @@
+#
+# Copyright (c) 2005 Thorsten Kukuk <kukuk@suse.de>
+#
+
+CLEANFILES = *~
+
+EXTRA_DIST = README $(MANS)
+
+man_MANS = pam_nologin.8
+
+securelibdir = $(SECUREDIR)
+secureconfdir = $(SCONFIGDIR)
+
+AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
+ -I$(top_srcdir)/modules/pammodutil/include/
+AM_LDFLAGS = -avoid-version -module \
+ -L$(top_builddir)/modules/pammodutil -lpammodutil \
+ -L$(top_builddir)/libpam -lpam
+
+securelib_LTLIBRARIES = pam_nologin.la
diff --git a/modules/pam_nologin/pam_nologin.8 b/modules/pam_nologin/pam_nologin.8
new file mode 100644
index 00000000..e68a6a15
--- /dev/null
+++ b/modules/pam_nologin/pam_nologin.8
@@ -0,0 +1,86 @@
+.\" Copyright (C) 2003 International Business Machines Corp.
+.\" This file is distributed according to the GNU General Public License.
+.\" See the file COPYING in the top level source directory for details.
+.\"
+.de Sh \" Subsection
+.br
+.if t .Sp
+.ne 5
+.PP
+\fB\\$1\fR
+.PP
+..
+.de Sp \" Vertical space (when we can't use .PP)
+.if t .sp .5v
+.if n .sp
+..
+.de Ip \" List item
+.br
+.ie \\n(.$>=3 .ne \\$3
+.el .ne 3
+.IP "\\$1" \\$2
+..
+.TH "PAM_NOLOGIN" 8 "2003-03-21" "Linux 2.4" "System Administrator's Manual"
+.SH NAME
+pam_nologin \- Disables login for all except root when
+\fI/etc/nologin\fR exists
+.SH "SYNOPSIS"
+.ad l
+.hy 0
+
+/lib/security/pam_nologin
+.sp
+.ad
+.hy
+
+.SH "DESCRIPTION"
+
+.PP
+\fBpam_nologin\fR is a PAM module that prevents users from logging
+into the system when \fI/etc/nologin\fR exists.
+The contents of the \fI/etc/nologin\fR file are displayed to the user.
+The \fBpam_nologin\fR module has no effect on the root user's ability to log in.
+
+.SH "OPTIONS"
+
+.PP
+\fBpam_login\fR has no options.
+
+.SH "MODULE SERVICES PROVIDED"
+
+.TP
+auth
+_authentication and _setcred (blank)
+
+.SH "RETURN CODES"
+.PP
+\fBpam_nologin\fR has the following return codes:
+.TP
+PAM_SUCCESS
+Success: either the user is root or the \fI/etc/nologin\fR file does not exist.
+
+.TP
+PAM_SERVICE_ERR
+The module was unable to get the user name.
+
+.TP
+PAM_USER_UNKNOWN
+The module cannot get the UID associated with this user.
+
+.TP
+PAM_AUTH_ERR
+The user is not root and \fI/etc/nologin\fR exists, so the user is
+not permitted to log in.
+
+.SH "HISTORY"
+
+.PP
+\fBpam_nologin\fR was written by Michael K. Johnson.
+
+.SH "SEE ALSO"
+
+.PP
+\fBpam.conf\fR(8), \fBpam.d\fR(8), \fBpam\fR(8), \fBnologin\fR(8).
+
+.SH AUTHOR
+Emily Ratliff.