summaryrefslogtreecommitdiff
path: root/modules/pam_tally/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_tally/Makefile')
-rw-r--r--modules/pam_tally/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/modules/pam_tally/Makefile b/modules/pam_tally/Makefile
index 7949b558..1c5106e3 100644
--- a/modules/pam_tally/Makefile
+++ b/modules/pam_tally/Makefile
@@ -67,8 +67,8 @@ $(LIBOBJD): $(LIBSRC)
$(LIBSHARED): $(LIBOBJD)
$(LD_D) -o $@ $(LIBOBJD)
-$(APPLICATION): $(APPOBJD)
- $(CC) $(CFLAGS) -o $@ $< $(LOADLIBES)
+$(APPLICATION): $(APPOBJD) $(TITLE).c
+ $(CC) $(CFLAGS) -o $@ $(APPOBJD) $(LOADLIBES)
endif
@@ -78,8 +78,8 @@ $(LIBOBJS): $(LIBSRC)
$(LIBSTATIC): $(LIBOBJS)
$(LD) -r -o $@ $(LIBOBJS)
-$(APPLICATION): $(APPOBJS)
- $(CC) $(CFLAGS) -o $@ $< $(LOADLIBES)
+$(APPLICATION): $(APPOBJS) $(TITLE).c
+ $(CC) $(CFLAGS) -o $@ $(APPOBJS) $(LOADLIBES)
endif
install: all
@@ -88,7 +88,7 @@ ifdef DYNAMIC
$(INSTALL) -m $(SHLIBMODE) $(LIBSHARED) $(FAKEROOT)$(SECUREDIR)
endif
$(MKDIR) $(FAKEROOT)$(SUPLEMENTED)
-# $(INSTALL) -m $(APPMODE) $(APPLICATION) $(FAKEROOT)$(SUPLEMENTED)
+ $(INSTALL) -m $(APPMODE) $(APPLICATION) $(FAKEROOT)$(SUPLEMENTED)
remove:
rm -f $(FAKEROOT)$(SECUREDIR)/$(TITLE).so