summaryrefslogtreecommitdiff
path: root/modules/pam_warn
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_warn')
-rw-r--r--modules/pam_warn/.cvsignore1
-rw-r--r--modules/pam_warn/Makefile15
-rw-r--r--modules/pam_warn/README26
-rw-r--r--modules/pam_warn/pam_warn.c127
4 files changed, 0 insertions, 169 deletions
diff --git a/modules/pam_warn/.cvsignore b/modules/pam_warn/.cvsignore
deleted file mode 100644
index 380a834a..00000000
--- a/modules/pam_warn/.cvsignore
+++ /dev/null
@@ -1 +0,0 @@
-dynamic
diff --git a/modules/pam_warn/Makefile b/modules/pam_warn/Makefile
deleted file mode 100644
index 44c56f17..00000000
--- a/modules/pam_warn/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# $Id$
-#
-# This Makefile controls a build process of $(TITLE) module for
-# Linux-PAM. You should not modify this Makefile (unless you know
-# what you are doing!).
-#
-# Created by Andrew Morgan <morgan@linux.kernel.org> 2000/08/27
-#
-
-include ../../Make.Rules
-
-TITLE=pam_warn
-
-include ../Simple.Rules
diff --git a/modules/pam_warn/README b/modules/pam_warn/README
deleted file mode 100644
index 6d484bdf..00000000
--- a/modules/pam_warn/README
+++ /dev/null
@@ -1,26 +0,0 @@
-# $Id$
-#
-
-This module is an authentication module that does not authenticate.
-Instead it always returns PAM_IGNORE, indicating that it does not want
-to affect the authentication process.
-
-Its purpose is to log a message to the syslog indicating the
-pam_item's available at the time it was invoked. It is a diagnostic
-tool.
-
-Recognized arguments:
-
- <none>
-
-module services provided:
-
- auth _authenticate and _setcred (blank)
- acct _acct_mgmt [mapped to _authenticate]
- session _open_session and
- _close_session [mapped to _authenticate ]
- password _chauthtok [mapped to _authenticate]
-
-
-Andrew Morgan
-1996/11/14
diff --git a/modules/pam_warn/pam_warn.c b/modules/pam_warn/pam_warn.c
deleted file mode 100644
index f167ea91..00000000
--- a/modules/pam_warn/pam_warn.c
+++ /dev/null
@@ -1,127 +0,0 @@
-/* pam_warn module */
-
-/*
- * $Id$
- *
- * Written by Andrew Morgan <morgan@linux.kernel.org> 1996/3/11
- */
-
-#define _BSD_SOURCE
-
-#include <stdio.h>
-#include <unistd.h>
-#include <syslog.h>
-#include <stdarg.h>
-
-/*
- * here, we make a definition for the externally accessible function
- * in this file (this definition is required for static a module
- * but strongly encouraged generally) it is used to instruct the
- * modules include file to define the function prototypes.
- */
-
-#define PAM_SM_AUTH
-#define PAM_SM_PASSWORD
-
-#include <security/pam_modules.h>
-
-/* some syslogging */
-
-#define OBTAIN(item, value, default_value) do { \
- (void) pam_get_item(pamh, item, (const void **) &value); \
- value = value ? value : default_value ; \
-} while (0)
-
-static void _pam_log(int err, const char *format, ...)
-{
- va_list args;
-
- va_start(args, format);
- openlog("PAM-warn", LOG_CONS|LOG_PID, LOG_AUTH);
- vsyslog(err, format, args);
- va_end(args);
- closelog();
-}
-
-static void log_items(pam_handle_t *pamh, const char *function)
-{
- const char *service=NULL, *user=NULL, *terminal=NULL,
- *rhost=NULL, *ruser=NULL;
-
- OBTAIN(PAM_SERVICE, service, "<unknown>");
- OBTAIN(PAM_TTY, terminal, "<unknown>");
- OBTAIN(PAM_USER, user, "<unknown>");
- OBTAIN(PAM_RUSER, ruser, "<unknown>");
- OBTAIN(PAM_RHOST, rhost, "<unknown>");
-
- _pam_log(LOG_NOTICE, "function=[%s] service=[%s] terminal=[%s] user=[%s]"
- " ruser=[%s] rhost=[%s]\n",
- function, service, terminal, user, ruser, rhost);
-}
-
-/* --- authentication management functions (only) --- */
-
-PAM_EXTERN
-int pam_sm_authenticate(pam_handle_t *pamh, int flags, int argc,
- const char **argv)
-{
- log_items(pamh, __FUNCTION__);
- return PAM_IGNORE;
-}
-
-PAM_EXTERN
-int pam_sm_setcred(pam_handle_t *pamh, int flags, int argc, const char **argv)
-{
- log_items(pamh, __FUNCTION__);
- return PAM_IGNORE;
-}
-
-/* password updating functions */
-
-PAM_EXTERN
-int pam_sm_chauthtok(pam_handle_t *pamh,int flags,int argc,const char **argv)
-{
- log_items(pamh, __FUNCTION__);
- return PAM_IGNORE;
-}
-
-PAM_EXTERN int
-pam_sm_acct_mgmt (pam_handle_t *pamh, int flags, int argc, const char **argv)
-{
- log_items(pamh, __FUNCTION__);
- return PAM_IGNORE;
-}
-
-PAM_EXTERN int
-pam_sm_open_session (pam_handle_t *pamh, int flags, int argc,
- const char **argv)
-{
- log_items(pamh, __FUNCTION__);
- return PAM_IGNORE;
-}
-
-PAM_EXTERN int
-pam_sm_close_session (pam_handle_t *pamh, int flags, int argc,
- const char **argv)
-{
- log_items(pamh, __FUNCTION__);
- return PAM_IGNORE;
-}
-
-#ifdef PAM_STATIC
-
-/* static module data */
-
-struct pam_module _pam_warn_modstruct = {
- "pam_warn",
- pam_sm_authenticate,
- pam_sm_setcred,
- pam_sm_acct_mgmt,
- pam_sm_open_session,
- pam_sm_close_session,
- pam_sm_chauthtok,
-};
-
-#endif
-
-/* end of module definition */