summaryrefslogtreecommitdiff
path: root/modules/pam_xauth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_xauth/Makefile.am')
-rw-r--r--modules/pam_xauth/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/modules/pam_xauth/Makefile.am b/modules/pam_xauth/Makefile.am
index 78ff1d78..8f1d56b0 100644
--- a/modules/pam_xauth/Makefile.am
+++ b/modules/pam_xauth/Makefile.am
@@ -4,9 +4,10 @@
CLEANFILES = *~
-man_MANS = pam_xauth.8
+EXTRA_DIST = README ${MANS} $(XMLS) tst-pam_xauth
-EXTRA_DIST = README ${MANS} tst-pam_xauth
+man_MANS = pam_xauth.8
+XMLS = README.xml pam_xauth.8.xml
TESTS = tst-pam_xauth
@@ -21,3 +22,10 @@ if HAVE_VERSIONING
endif
securelib_LTLIBRARIES = pam_xauth.la
+
+if ENABLE_REGENERATE_MAN
+noinst_DATA = README
+README: pam_xauth.8.xml
+-include $(top_srcdir)/Make.xml.rules
+endif
+