summaryrefslogtreecommitdiff
path: root/debian/control
Commit message (Collapse)AuthorAge
* Build-depend on debhelper 8.9.4 and bump debian/compat to 9 forSteve Langasek2019-01-08
| | | | | dpkg-buildflags integration, and drop manual setting of -g -O options in CFLAGS now that we can let dh do it for us
* debian/control: adjust the package descriptions, as the current onesSteve Langasek2019-01-08
| | | | | | use some awkward language that's gone unnoticed for a long time. Thanks to Martin Eberhard Schauer <Martin.E.Schauer@gmx.de> for pointing this out. Closes: #633863.
* mark libpam0g-dev M-A: sameSteve Langasek2019-01-08
|
* Pull in final multiarch support from Ubuntu:Steve Langasek2019-01-08
| | | | | | | | | - bump the debhelper build-dep - add Pre-Depends: ${misc:Pre-Depends} for multiarch-support - add Pre-Depends: libpam0g (>= 1.1.3-2) to libpam-modules - bump the version in libpam-modules-bin's replaces: of libpam-modules - use DEB_HOST_MULTIARCH, not DEB_HOST_GNU_TYPE
* merge from squeezeSteve Langasek2019-01-08
|\
| * Bump Standards-Version to 3.9.1.Steve Langasek2019-01-08
| |
* | bump replaces on libpam-modulesSteve Langasek2019-01-08
| |
* | merge from trunkSteve Langasek2019-01-08
|\ \ | |/
| * libpam0g no longer depends on libpam-runtime; packages that useSteve Langasek2019-01-08
| | | | | | | | | | | | /etc/pam.d/common-* must depend directly on libpam-runtime, and most do (including the Essential: yes ones), so let's break this circular dependency. Closes: #545086, LP: #424566.
* | merge from trunkSteve Langasek2019-01-08
|\ \ | |/
| * Move pam_cracklib manpage to the libpam-cracklib package, and add theSteve Langasek2019-01-08
| | | | | | | | requisite Replaces
| * Convert debian/rules to debhelper 7 and add versioned build-dependenciesSteve Langasek2019-01-08
| | | | | | | | on debhelper and quilt to suit.
* | Split libpam-modules into libpam-modules and libpam-modules-bin, so that weSteve Langasek2019-01-08
| | | | | | | | | | only have to have one copy of the helper binaries installed.
* | add the Multi-Arch fields to the packagesSteve Langasek2019-01-08
|/
* I am so far away from the whole pam thing these days that I am almostKarl Ramm2019-01-08
| | | | | guaranteed to break something if I upload.
* bump debhelper build-dep to 7 alsoSteve Langasek2019-01-08
|
* make libpam-runtime depend on libpam-modules (>= 1.0.1-6) - nothing elseSteve Langasek2019-01-08
| | | | guarantees that we have pam_unix available for use by pam-auth-update.
* Remove conflicts information for transitions prior to woody releaseSam Hartman2019-01-08
|
* debian/control: add missing misc:Depends for packages that need it.Kees Cook2019-01-08
|
* Move the pam module packages to section 'admin'.Steve Langasek2019-01-08
|
* bump the versioned dep on libpam-runtime as wellSteve Langasek2019-01-03
|
* catch up with Debian unstableSteve Langasek2019-01-03
|\
| * have libpam-modules Pre-Depend on ${misc:Depends} and add a debconf question toSteve Langasek2019-01-03
| | | | | | | | | | | | the libpam-modules preinst, so we can reliably warn users about xscreensaver and xlockmore before libpam-modules is unpacked; at the same time, clean up the text of the libpam0g debconf template to not refer to the screensavers.
| * Have libpam-modules Pre-Depend on its shlibs, to force libpam0g to beSteve Langasek2019-01-03
| | | | | | | | | | | | | | configured before libpam-modules is unpacked and allowing us to warn users about needing to disable xscreensaver and xlockmore at the right time without having to add a pre-dependency on debconf to these transitively essential packages. Closes: #502140, LP: #256238.
| * Build-conflict with libxcrypt-dev, which otherwise pulls libxcrypt in asSteve Langasek2019-01-03
| | | | | | | | | | a dependency of libpam-modules if it's installed during the build. Thanks to Larry Doolittle for catching.
* | libpam-runtime depends only on debconf (>= 1.5.19), with no alternative forSteve Langasek2019-01-03
| | | | | | | | | | | | cdebconf; discussion on debian-devel reveals that only debconf itself provides the confmodule portion these days, so we must have the correct version of debconf regardless of whether cdebconf is also installed.
* | libpam-runtime needs a versioned dep on debconf, because it uses ↵Steve Langasek2019-01-03
| | | | | | | | x_loadtemplatefile
* | bump the referenced version number again for one /really/ final pam upload toSteve Langasek2019-01-03
| | | | | | | | | | | | lenny, and update the checksums to point at the current template versions (replacing the previous md5sums, since that version was never uploaded to Debian)
* | bump the version check to 1.0.1-4; we had to upload 1.0.1-3 as a security fixSteve Langasek2019-01-03
| |
* | libpam-cracklib: versioned depend on libpam-runtime, and invoke pam-auth-configSteve Langasek2019-01-03
| | | | | | | | in the postinst
* | turn on for libpam-runtime, because of debconfSteve Langasek2019-01-03
|/
* Build-Conflict with libdb4.2-dev, which satisfies the libdb-devSteve Langasek2019-01-03
| | | | | build-dependency but causes pam_userdb to be silently omitted. Closes: #493574.
* Bump Standards-Version to 3.8.0.Steve Langasek2019-01-03
|
* Fix a typo in the libpam0g-dev description.Steve Langasek2019-01-03
|
* Replace the Vcs-Svn field with a Vcs-Bzr field; jumping ship from svn, andSteve Langasek2019-01-03
| | | | how!
* fix-up commit for grafting svn history onto git historySteve Langasek2019-01-02