summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn MacFarlane <fiddlosopher@gmail.com>2012-10-28 09:36:15 -0700
committerJohn MacFarlane <fiddlosopher@gmail.com>2012-10-28 09:36:15 -0700
commit06300e59d51d1040a95e961c7419794b422cbdee (patch)
tree10c141d8e045d23b4502f605d8b511df8f0bca64
parent6f2347635ca86f4152e71ad766fea486692dd63d (diff)
Removed citationSuppressParens.
Makefile: Use citeproc-0.3.6 release.
-rw-r--r--Makefile4
-rw-r--r--pandoc.cabal2
-rw-r--r--src/Text/Pandoc/Readers/LaTeX.hs1
-rw-r--r--tests/Tests/Readers/LaTeX.hs2
-rw-r--r--tests/latex-reader.native2
5 files changed, 5 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 272e921ca..7948d1f2c 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ all:
prof:
cabal-dev configure --enable-tests --enable-library-profiling --enable-executable-profiling && cabal-dev build
-prep: pandoc-types citeproc-hs
+prep: pandoc-types
cabal-dev update && \
cabal-dev install-deps --enable-library-profiling --enable-tests --enable-benchmarks
@@ -31,7 +31,7 @@ pandoc-types:
citeproc-hs: pandoc-types
darcs get --lazy http://gorgias.mine.nu/repos/citeproc-hs && \
- cabal-dev add-source citeproc-hs
+ cabal-dev add-source citeproc-hs
install:
cabal-dev install --enable-tests --enable-benchmarks
diff --git a/pandoc.cabal b/pandoc.cabal
index 369c662f5..2a56381ad 100644
--- a/pandoc.cabal
+++ b/pandoc.cabal
@@ -218,7 +218,7 @@ Library
xml >= 1.3.12 && < 1.4,
random >= 1 && < 1.1,
extensible-exceptions >= 0.1 && < 0.2,
- citeproc-hs >= 0.3.4 && < 0.4,
+ citeproc-hs >= 0.3.6 && < 0.4,
pandoc-types >= 1.10 && < 1.11,
json >= 0.4 && < 0.8,
tagsoup >= 0.12.5 && < 0.13,
diff --git a/src/Text/Pandoc/Readers/LaTeX.hs b/src/Text/Pandoc/Readers/LaTeX.hs
index 5a2b7b6c1..14efedef4 100644
--- a/src/Text/Pandoc/Readers/LaTeX.hs
+++ b/src/Text/Pandoc/Readers/LaTeX.hs
@@ -909,7 +909,6 @@ simpleCiteArgs = try $ do
, citationMode = NormalCitation
, citationHash = 0
, citationNoteNum = 0
- , citationSuppressParens = False
}
return $ addPrefix pre $ addSuffix suf $ map conv keys
diff --git a/tests/Tests/Readers/LaTeX.hs b/tests/Tests/Readers/LaTeX.hs
index 19e0aa4dd..271b32689 100644
--- a/tests/Tests/Readers/LaTeX.hs
+++ b/tests/Tests/Readers/LaTeX.hs
@@ -68,7 +68,7 @@ baseCitation = Citation{ citationId = "item1"
, citationMode = AuthorInText
, citationNoteNum = 0
, citationHash = 0
- , citationSuppressParens = False }
+ }
rt :: String -> Inlines
rt = rawInline "latex"
diff --git a/tests/latex-reader.native b/tests/latex-reader.native
index 6ddcac6d7..67a4e9011 100644
--- a/tests/latex-reader.native
+++ b/tests/latex-reader.native
@@ -260,7 +260,7 @@ Pandoc (Meta {docTitle = [Str "Pandoc",Space,Str "Test",Space,Str "Suite"], docA
,HorizontalRule
,Header 1 [Str "LaTeX"]
,BulletList
- [[Para [Cite [Citation {citationId = "smith.1899", citationPrefix = [], citationSuffix = [Str ",",Space,Str "22-23"], citationMode = AuthorInText, citationNoteNum = 0, citationSuppressParens = False, citationHash = 0}] [RawInline "latex" "\\cite[22-23]{smith.1899}"]]]
+ [[Para [Cite [Citation {citationId = "smith.1899", citationPrefix = [], citationSuffix = [Str ",",Space,Str "22-23"], citationMode = AuthorInText, citationNoteNum = 0, citationHash = 0}] [RawInline "latex" "\\cite[22-23]{smith.1899}"]]]
,[Para [RawInline "latex" "\\doublespacing"]]
,[Para [Math InlineMath "2+2=4"]]
,[Para [Math InlineMath "x \\in y"]]