summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-02-05 12:15:02 +0100
committerJohn MacFarlane <jgm@berkeley.edu>2017-02-05 12:15:02 +0100
commit18bc0a67ebf4f49a5f8ea41d03d9b45e74d5d207 (patch)
treec3164399e93449ca4c12c85347315991d081add4
parent5f2f2efe3225c64f7c822dab035286b2913b5c5c (diff)
Makefile: added BRANCH variable for winpkg
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ab7e0fcf8..390af80bd 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,6 @@
version=$(shell grep '^Version:' pandoc.cabal | awk '{print $$2;}')
pandoc=$(shell find dist -name pandoc -type f -exec ls -t {} \; | head -1)
+BRANCH?=master
quick:
stack install --flag 'pandoc:embed_data_files' --fast --test --test-arguments='-j4'
@@ -33,7 +34,7 @@ macospkg: man/pandoc.1
winpkg: pandoc-$(version)-windows.msi
pandoc-$(version)-windows.msi:
- wget 'https://ci.appveyor.com/api/projects/jgm/pandoc/artifacts/windows/pandoc.msi?branch=master' -O pandoc.msi && \
+ wget 'https://ci.appveyor.com/api/projects/jgm/pandoc/artifacts/windows/pandoc.msi?branch=$(BRANCH)' -O pandoc.msi && \
osslsigncode sign -pkcs12 ~/Private/ComodoCodeSigning.exp2017.p12 -in pandoc.msi -i http://johnmacfarlane.net/ -t http://timestamp.comodoca.com/ -out $@ -askpass
rm pandoc.msi