summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-12-27 14:09:48 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2017-12-27 14:09:48 -0800
commit4371b07cd103863d8a0ec06fa4ecf78ad5eb3a27 (patch)
treebc948ab6a918d423558e6e505bc67f9ebd67218f
parent18da5443ff52ba5124e86998ad599b288a478bbc (diff)
Added 'make trypandoc' target
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5fc2b3d66..9754c628f 100644
--- a/Makefile
+++ b/Makefile
@@ -93,7 +93,10 @@ pandoc-templates:
git commit -m "Updated templates for pandoc $(version)" && \
popd
+trypandoc:
+ ssh -t macfarlane 'cd src/pandoc && git pull && ~/.local/bin/stack install --flag pandoc:trypandoc --flag pandoc:embed_data_files && cd trypandoc && sudo make install'
+
clean:
stack clean
-.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates
+.PHONY: deps quick full haddock install clean test bench changes_github macospkg dist prof download_stats reformat lint weigh doc/lua-filters.md packages pandoc-templates trypandoc